summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-45.3.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 3189df9f6ace..c027c59cbf58 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-44.6.tar.xz 3994776 BLAKE2B e73fc66d7138961b61085538daf15c0d93a13827a9fcef62f111ddee87541a0fb61a9fb8fba7814c613da8179c895ddedcc22e2838885aa9222c327609968dfb SHA512 9af157db0f7a68d64fec9fd17465ee8cc900879a3613c3f3e03ea27938a84c0dda6be30b4d1d2cc0f9ddba5cf5d41de3d3156b0580fdce03b1d8f920bb96536c
+DIST epiphany-45.3.tar.xz 4005168 BLAKE2B 9f8965d310efcfa21e133a24a29ce97ffff94e0b202be599bb83085095c77f93f81e6ef248d9b844e0790d35712471c2f27dd31fc808d6244b59251df26ae468 SHA512 4fac6b21dc40f77312e7c9367cb4d0e4ef292d1a30c3759405543fc372b044f9de98523854a0da7a4024a1429ce35b5513160a2977fb361d71a7a86d94dbf596
diff --git a/www-client/epiphany/epiphany-45.3.ebuild b/www-client/epiphany/epiphany-45.3.ebuild
new file mode 100644
index 000000000000..db78c1770324
--- /dev/null
+++ b/www-client/epiphany/epiphany-45.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web https://gitlab.gnome.org/GNOME/epiphany"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.9.0:4=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=dev-libs/glib-2.74.0:2
+ gnome-base/gsettings-desktop-schemas
+ >=media-libs/gstreamer-1.0
+ >=gui-libs/gtk-4.10.0:4
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=gui-libs/libadwaita-1.4.0:1
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.99.4:3.0
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/nettle-3.4:=
+ >=dev-libs/libportal-0.6:0=[gtk]
+ >=dev-db/sqlite-3.22:3
+ >=net-libs/webkit-gtk-2.41.1:6=
+
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ -Dgranite=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk:6[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk:6 is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}