summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.0-r103.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/dev-lua/luaexpat/luaexpat-1.3.0-r103.ebuild b/dev-lua/luaexpat/luaexpat-1.3.0-r103.ebuild
deleted file mode 100644
index 1780a3316e3c..000000000000
--- a/dev-lua/luaexpat/luaexpat-1.3.0-r103.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library"
-HOMEPAGE="https://matthewwild.co.uk/projects/luaexpat/ https://code.matthewwild.co.uk/lua-expat"
-SRC_URI="https://matthewwild.co.uk/projects/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- dev-libs/expat
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "doc/us/." )
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- # Remove '-ansi' to compile with newer lua versions
- sed -e 's/-O2//g' -e 's/-ansi//g' -i Makefile || die
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INC=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CDIR=$(lua_get_cmod_dir)"
- "LUA_INC=$(lua_get_include_dir)"
- "LUA_LDIR=$(lua_get_lmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}