summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/referencing/Manifest1
-rw-r--r--dev-python/referencing/referencing-0.33.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/referencing/Manifest b/dev-python/referencing/Manifest
index 35e5406de75f..0e78c29639a8 100644
--- a/dev-python/referencing/Manifest
+++ b/dev-python/referencing/Manifest
@@ -1 +1,2 @@
DIST referencing-0.32.1.tar.gz 55523 BLAKE2B 7312158a6bfeef64d4f2ff8f7332d3153b2e03954a48f42c904ae68d652b819df579b8188dc9a62aa024a658d300b59166f866ff351a20565b4b01c1d259e95d SHA512 a1171758b76d249f1d57f47ffc9c06882fff17ae3f04b91dfc5d14e0e15157827129b2328e143b6699b7890ad23d47aeed4a6d8e44dc116c368b8de624df7074
+DIST referencing-0.33.0.tar.gz 55507 BLAKE2B 6781b3295a1727ed0d6cdb17ca9b8e63d974463ccebb6064cb153a5523a7912c41525d03b8baa7eb17e4165880b75a738648a318a9415be5d9d6459622ed5803 SHA512 053ae200401c415a887ebead387d3378ead4c1c98d7f37a0130fd5b8d0c9ce86848591f8e47e59e0e2d0a596a49a450fdad3ffb5246b369ffdc4f2c31e9edddd
diff --git a/dev-python/referencing/referencing-0.33.0.ebuild b/dev-python/referencing/referencing-0.33.0.ebuild
new file mode 100644
index 000000000000..9bb63870e54d
--- /dev/null
+++ b/dev-python/referencing/referencing-0.33.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Cross-specification JSON referencing (JSON Schema, OpenAPI...)"
+HOMEPAGE="
+ https://github.com/python-jsonschema/referencing/
+ https://pypi.org/project/referencing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest