summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libhackrf/libhackrf-2018.01.1.ebuild5
-rw-r--r--net-libs/libhackrf/libhackrf-9999.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/net-libs/libhackrf/libhackrf-2018.01.1.ebuild b/net-libs/libhackrf/libhackrf-2018.01.1.ebuild
index 8acce1696f84..06468417d0d7 100644
--- a/net-libs/libhackrf/libhackrf-2018.01.1.ebuild
+++ b/net-libs/libhackrf/libhackrf-2018.01.1.ebuild
@@ -11,7 +11,6 @@ HOMEPAGE="http://greatscottgadgets.com/hackrf/"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
inherit git-r3
- KEYWORDS=""
EGIT_CHECKOUT_DIR="${WORKDIR}/hackrf"
S="${WORKDIR}/hackrf/host/libhackrf"
else
@@ -28,8 +27,8 @@ DEPEND="virtual/libusb:1"
RDEPEND="${DEPEND}"
src_configure() {
- mycmakeargs=(
- -DENABLE_INSTALL_UDEV_RULES="$(usex udev)"
+ local mycmakeargs=(
+ -DINSTALL_UDEV_RULES="$(usex udev)"
)
if use udev; then
mycmakeargs+=(
diff --git a/net-libs/libhackrf/libhackrf-9999.ebuild b/net-libs/libhackrf/libhackrf-9999.ebuild
index 8acce1696f84..06468417d0d7 100644
--- a/net-libs/libhackrf/libhackrf-9999.ebuild
+++ b/net-libs/libhackrf/libhackrf-9999.ebuild
@@ -11,7 +11,6 @@ HOMEPAGE="http://greatscottgadgets.com/hackrf/"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
inherit git-r3
- KEYWORDS=""
EGIT_CHECKOUT_DIR="${WORKDIR}/hackrf"
S="${WORKDIR}/hackrf/host/libhackrf"
else
@@ -28,8 +27,8 @@ DEPEND="virtual/libusb:1"
RDEPEND="${DEPEND}"
src_configure() {
- mycmakeargs=(
- -DENABLE_INSTALL_UDEV_RULES="$(usex udev)"
+ local mycmakeargs=(
+ -DINSTALL_UDEV_RULES="$(usex udev)"
)
if use udev; then
mycmakeargs+=(