summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/polymc/polymc-1.2.1.ebuild4
-rw-r--r--games-action/polymc/polymc-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/games-action/polymc/polymc-1.2.1.ebuild b/games-action/polymc/polymc-1.2.1.ebuild
index d488a775fb9a..00e26da2635e 100644
--- a/games-action/polymc/polymc-1.2.1.ebuild
+++ b/games-action/polymc/polymc-1.2.1.ebuild
@@ -77,7 +77,9 @@ RDEPEND="
virtual/opengl
"
-PATCHES=( "${FILESDIR}/${PN}-iconfix.patch" )
+if [[ ${PV} != 9999 ]]; then
+ PATCHES=( "${FILESDIR}/${PN}-iconfix.patch" )
+fi
src_prepare() {
cmake_src_prepare
diff --git a/games-action/polymc/polymc-9999.ebuild b/games-action/polymc/polymc-9999.ebuild
index d488a775fb9a..00e26da2635e 100644
--- a/games-action/polymc/polymc-9999.ebuild
+++ b/games-action/polymc/polymc-9999.ebuild
@@ -77,7 +77,9 @@ RDEPEND="
virtual/opengl
"
-PATCHES=( "${FILESDIR}/${PN}-iconfix.patch" )
+if [[ ${PV} != 9999 ]]; then
+ PATCHES=( "${FILESDIR}/${PN}-iconfix.patch" )
+fi
src_prepare() {
cmake_src_prepare