summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/fsharp-mode/Manifest1
-rw-r--r--app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/fsharp-mode/Manifest b/app-emacs/fsharp-mode/Manifest
index e632bbab6805..1e4b396b435d 100644
--- a/app-emacs/fsharp-mode/Manifest
+++ b/app-emacs/fsharp-mode/Manifest
@@ -1 +1,2 @@
DIST fsharp-mode-2.0.tar.gz 80880 BLAKE2B e8de665216ac9e147d63d168abc9aebf3cf2ca6a5a6ea9f8afe45c3329d692fa0342a1c3afb982dcdb1b59e1f348e1a307e0ce6a09f708c782b32595bc74106f SHA512 bcb95995604404c42147b636d101dfcaba61945b7ef30196a0e41c138bfd0901c744ca73e36438bae14c1727030f05fc4fcc07aef06f25d46394777ff58537db
+DIST fsharp-mode-2.0_p20230622.tar.gz 82036 BLAKE2B 0a23200925a475ca4a046bd4ece13fd994bead0d021a5e0dff6d0494637b52f6113d8d1cb22d4e9505ae13a0033c48f205dea8690b9793ea5f9d6b0dc62419c2 SHA512 2385039129d09b3e037168e488f7e7867d862ba52ccfcf4f4713d648e516ca14a25aa7a879cd3adcc09d91c571a374c4573d3b3f50bba0cf800e48e953266e07
diff --git a/app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild b/app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild
new file mode 100644
index 000000000000..f01f85ed5720
--- /dev/null
+++ b/app-emacs/fsharp-mode/fsharp-mode-2.0_p20230622.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=b4d31c3da018cfbb3d1f9e6fd416d8777f0835bd
+NEED_EMACS=29.1 # To compile full suite including Eglot, introduced in 29.1.
+
+inherit elisp
+
+DESCRIPTION="Support for the F# programming language"
+HOMEPAGE="https://github.com/fsharp/emacs-fsharp-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fsharp/emacs-${PN}.git"
+else
+ SRC_URI="https://github.com/fsharp/emacs-${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-${PN}-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DOCS=( CHANGELOG.md README.org )
+ELISP_REMOVE="test/fsi-tests.el test/integration-tests.el"
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test