summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/parallel/Manifest1
-rw-r--r--dev-ruby/parallel/parallel-1.19.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/parallel/Manifest b/dev-ruby/parallel/Manifest
index 716be3846c0f..4fb4a92a932f 100644
--- a/dev-ruby/parallel/Manifest
+++ b/dev-ruby/parallel/Manifest
@@ -1,2 +1,3 @@
DIST parallel-1.17.0.tar.gz 20882 BLAKE2B a8afb329de1d8d0d577c1b53d990c4f1cd8ec9f23b8cc1005310903954f180c52535e3d8a5901862f1504da0981f3e16cf73a848403ed49872aa3dc45781b888 SHA512 92c7f4475a791da4feb0afda3686a4f9e9cc397ac278560c177552abf586054594d29a67b583845b69433e7824c0ce36bcffe98e13051242db0e5ee4a3c7a17c
DIST parallel-1.18.0.tar.gz 21095 BLAKE2B d47286c719810699cd5098b9d28e4e00cec2a7a27141a2dd932023f9fdeaac389f2be9aa8196820ad3d28d26c141f41565ad363fdca9bbca75e18a8d9d7fa4b5 SHA512 2869a8b82da2b1f2595be04616afa5bce62eac3833d743304dc4371db63be7645437c009c202d4690fe5dc221766e2a0f25790335d7a25b355c3f3b8034f8319
+DIST parallel-1.19.0.tar.gz 21216 BLAKE2B a4160bd1d4b533be3ec4d87ade0b4ea793e0e8e7bf2f4ec2cccd17dc2166276a167b85f0a55af46c74937641917ecff435457a0b3f2d565791c3b462143750eb SHA512 0bb0f98f2697b9e9fc851f7a060135e17c92add8980692042d16ad2ae260bda6045f03f70fc533ae259b41d8b80a388e5a26fffecd923851b9228e98b792478b
diff --git a/dev-ruby/parallel/parallel-1.19.0.ebuild b/dev-ruby/parallel/parallel-1.19.0.ebuild
new file mode 100644
index 000000000000..c7ad1888fe50
--- /dev/null
+++ b/dev-ruby/parallel/parallel-1.19.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="parallel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run any code in parallel Processes or Threads"
+HOMEPAGE="https://github.com/grosser/parallel"
+LICENSE="MIT"
+SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+SLOT="1"
+IUSE="test"
+
+DEPEND+="test? ( sys-process/lsof )"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:5.2 dev-ruby/sqlite3 )"
+
+each_ruby_prepare() {
+ # Make sure the correct ruby is used for testing
+ sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
+}
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '1i require "tempfile"; gem "activerecord", "~>5.2.0"' spec/cases/helper.rb || die
+ sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
+
+ # Avoid a failing spec regarding to pipes. The spec seems like it
+ # should always fail.
+ sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
+ -i spec/parallel_spec.rb || die
+
+ # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
+ sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
+
+ # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
+ sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
+}
+
+each_ruby_test() {
+ # Set RUBYLIB explicitly for the ruby's that get started from the specs.
+ TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
+}