summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.22.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index ff3ad059b142..46166f3aca11 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1,2 +1,3 @@
DIST jc-1.21.0.gh.tar.gz 11910267 BLAKE2B 7d02f6b574dc2171daca9682ef5cfe2ccdba6230320fc331c086c47b147e49efbd11fcb7b7f26bf4d448d4462f051b5b6892eff16e853cdb6cc4927f5cffddba SHA512 5382aba5c6ea0409fae31097516912d07133d2c14eb529e9df742f2efe4682c7e36e934786c9b12454d23e4c3acd5bdce3e97f410303b761f695db787058b034
DIST jc-1.21.2.gh.tar.gz 11910311 BLAKE2B ece8651c55f62821e30574cc208f3e1a569a2408ae1c637329556d49aae894afd7a57cdb7c70a0fdd16136fddd7329a1cefab493848376f22d5fae553c0231eb SHA512 3860e429a11131b888fa0689dd627016d3e9c052908979c22eca604281f13ba3df7164cdfa04ff6e4e08146b42d7bd76888efdcce65a549d5c904ecd207209f0
+DIST jc-1.22.0.gh.tar.gz 12062944 BLAKE2B 8a4f301c563cabb5ee780280d3aa3caa64a8cbab7972c67854e0c7fb53ba86c6cae12682f6bc8559d51ef692e0352378c01a223848249c0f8f3b664bad63e7ce SHA512 832ef3d209bbf6e3d3a4b7b038e80fc0dcb99d4ba38732ad393fdbe59be4f5d86428cfbbdb81f48d5902b31bdea635996a99aeada19361d74c991e711560767e
diff --git a/dev-python/jc/jc-1.22.0.ebuild b/dev-python/jc/jc-1.22.0.ebuild
new file mode 100644
index 000000000000..7b7bbfc30991
--- /dev/null
+++ b/dev-python/jc/jc-1.22.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest