summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.0.7.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 9f87c84a03da..5758da710579 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-2.0.5.tar.gz 150803 BLAKE2B c7d5ab17c3471b050a321c687e5faf33b5faad5a1afc60462b759280cff31bc55d86decdcb16dda9a4afe47848bc06f303c9697941dc212f01b28db6a8469a5e SHA512 bb2ef725e7dccefa640fe1568d1fee016bc5c639769d1b0d099067108e1369b8f7ccd3e48f985d657c5c7c33730eae891624f2c0ee2deaed491826b8c0eae2a5
+DIST pyscard-2.0.7.tar.gz 152304 BLAKE2B 8be34283b85b830597f051fedcdbe4437b81ad6ecf9dc0304e5bbb74f9af4fec36acc8d843802d59a204d75a4792f74827b5f422a9452cb0d84fe0ed51e4c2b3 SHA512 d30a2d0fe9b410f277a4a1e45ae88a30eb3aa7ef6cac683a80d2bb3cfe38aeafe6a483dfd42c50017c46ee0d26da13f7226e25e783176587eafce1988127bb67
diff --git a/dev-python/pyscard/pyscard-2.0.7.ebuild b/dev-python/pyscard/pyscard-2.0.7.ebuild
new file mode 100644
index 000000000000..9fc120662e2d
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}