summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/parallel/Manifest1
-rw-r--r--dev-ruby/parallel/parallel-1.12.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/parallel/Manifest b/dev-ruby/parallel/Manifest
index 433a850a4908..d92e515dc455 100644
--- a/dev-ruby/parallel/Manifest
+++ b/dev-ruby/parallel/Manifest
@@ -1 +1,2 @@
DIST parallel-1.11.2.tar.gz 20403 SHA256 cc8d3916f66b3bfd1acf87d27ee47fb7dcf71efe3551186d97ca79dea9ce3fce SHA512 4763abeb76ba50000eb88c85f661a794d784e457ed7ba6bd1367e65d802006bfd05cad017fb9a8fa3ca45ee87bb54c2dda218099fe78b2f6f36b05632d2ccd3d WHIRLPOOL 2d1864f9dc4bce5378355668a1fe287832891945958dfcce3856f25e134e1681af9d91fa6cd2774816c0315b371677b6c9f7a7d8e9fb33666ad8bf891c9b35e6
+DIST parallel-1.12.0.tar.gz 20472 SHA256 9e6666088f56f4abfb5b1f4f44f74b93b245ef3ca07dc671aeccb59a39df5f9b SHA512 8ca41cf577ee4743ef50abe693d0040eaab12b61eca17c3d6c33d3720c38563e2df9a0eb5af0fe9d8c34c3b910f1c626ce141fd2eb7d2edfbe5abbcb9f54191b WHIRLPOOL bcb5b83750f70dbce52ced22b8a5bf944fdd660276665be970abf81516ee214528ed9b437931ead1a000592c10e72f62d96a159c6dc9d2e3f4496f17d9f5c0a2
diff --git a/dev-ruby/parallel/parallel-1.12.0.ebuild b/dev-ruby/parallel/parallel-1.12.0.ebuild
new file mode 100644
index 000000000000..ae6e3c6512aa
--- /dev/null
+++ b/dev-ruby/parallel/parallel-1.12.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run any code in parallel Processes or Threads"
+HOMEPAGE="https://github.com/grosser/parallel"
+LICENSE="MIT"
+SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+SLOT="1"
+IUSE="test"
+
+DEPEND+="test? ( sys-process/lsof )"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:4.2 dev-ruby/sqlite3 )"
+
+each_ruby_prepare() {
+ # Make sure the correct ruby is used for testing
+ sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
+}
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '1i require "tempfile"; gem "activerecord", "~>4.2.0"' spec/cases/helper.rb || die
+ sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
+
+ # Avoid a failing spec regarding to pipes. The spec seems like it
+ # should always fail.
+ sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
+ -i spec/parallel_spec.rb || die
+
+ # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
+ sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
+
+ # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
+ sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
+}
+
+each_ruby_test() {
+ # Set RUBYLIB explicitly for the ruby's that get started from the specs.
+ TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
+}