summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/prefix-chain-setup/metadata.xml8
-rw-r--r--app-portage/prefix-chain-setup/prefix-chain-setup-0.6.ebuild223
-rw-r--r--app-portage/prefix-chain-setup/prefix-chain-setup-0.7.ebuild238
-rw-r--r--profiles/package.mask6
-rw-r--r--sys-apps/prefix-chain-utils/files/prefix-chain-wrapper.in83
-rw-r--r--sys-apps/prefix-chain-utils/files/startprefix.in45
-rw-r--r--sys-apps/prefix-chain-utils/metadata.xml8
-rw-r--r--sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r7.ebuild64
8 files changed, 0 insertions, 675 deletions
diff --git a/app-portage/prefix-chain-setup/metadata.xml b/app-portage/prefix-chain-setup/metadata.xml
deleted file mode 100644
index d33cce94b0d4..000000000000
--- a/app-portage/prefix-chain-setup/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>prefix@gentoo.org</email>
- <name>Gentoo Prefix</name>
-</maintainer>
-</pkgmetadata>
diff --git a/app-portage/prefix-chain-setup/prefix-chain-setup-0.6.ebuild b/app-portage/prefix-chain-setup/prefix-chain-setup-0.6.ebuild
deleted file mode 100644
index da26e810781f..000000000000
--- a/app-portage/prefix-chain-setup/prefix-chain-setup-0.6.ebuild
+++ /dev/null
@@ -1,223 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit prefix
-
-DESCRIPTION="Chained EPREFIX bootstrapping utility"
-HOMEPAGE="https://prefix.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~ppc-aix ~x64-cygwin ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}"
-
-src_install() {
- eprefixify ${PN}
- sed -e "s,@GENTOO_PORTAGE_CHOST@,${CHOST}," -i ${PN}
- dobin ${PN}
-}
-
-src_unpack() {
- { cat > "${PN}" || die; } <<'EOF'
-#!/usr/bin/env bash
-
-PARENT_EPREFIX="@GENTOO_PORTAGE_EPREFIX@"
-PARENT_CHOST="@GENTOO_PORTAGE_CHOST@"
-CHILD_EPREFIX=
-CHILD_PROFILE=
-DO_MINIMAL=no
-DO_SOURCES=no
-PORT_TMPDIR=
-
-#
-# get ourselfs the functions.sh script for ebegin/eend/etc.
-#
-for f in \
- /lib/gentoo/functions.sh \
- /etc/init.d/functions.sh \
- /sbin/functions.sh \
-; do
- if [[ -r ${PARENT_EPREFIX}${f} ]]; then
- . "${PARENT_EPREFIX}${f}"
- f=found
- break
- fi
-done
-
-if [[ ${f} != found ]]; then
- echo "Cannot find Gentoo functions, aborting." >&2
- exit 1
-fi
-
-for arg in "$@"; do
- case "${arg}" in
- --eprefix=*) CHILD_EPREFIX="${arg#--eprefix=}" ;;
- --profile=*) CHILD_PROFILE="${arg#--profile=}" ;;
- --sources) DO_SOURCES=yes ;;
- --portage-tmpdir=*) PORT_TMPDIR="${arg#--portage-tmpdir=}" ;;
-
- --help)
- einfo "$0 usage:"
- einfo " --eprefix=[PATH] Path to new EPREFIX to create chained to the prefix"
- einfo " where this script is installed (${PARENT_EPREFIX})"
- einfo " --profile=[PATH] The absolute path to the profile to use. This path"
- einfo " must point to a directory within ${PARENT_EPREFIX}"
- einfo " --sources inherit 'source' statements from the parent make.conf"
- einfo " --portage-tmpdir=DIR use DIR as portage temporary directory."
- exit 0
- ;;
- esac
-done
-
-#
-# sanity check of given values
-#
-
-test -n "${CHILD_EPREFIX}" || { eerror "no eprefix argument given"; exit 1; }
-test -d "${CHILD_EPREFIX}" && { eerror "${CHILD_EPREFIX} already exists"; exit 1; }
-test -n "${CHILD_PROFILE}" || { eerror "no profile argument given"; exit 1; }
-test -d "${CHILD_PROFILE}" || { eerror "${CHILD_PROFILE} does not exist"; exit 1; }
-if test -n "${PORT_TMPDIR}"; then
- if ! test -d "${PORT_TMPDIR}"; then
- einfo "creating temporary directory ${PORT_TMPDIR}"
- mkdir -p "${PORT_TMPDIR}"
- fi
-fi
-
-einfo "creating chained prefix ${CHILD_EPREFIX}"
-
-#
-# functions needed below.
-#
-eend_exit() {
- eend $1
- [[ $1 != 0 ]] && exit 1
-}
-
-#
-# create the directories required to bootstrap the least.
-#
-ebegin "creating directory structure"
-(
- set -e
- mkdir -p "${CHILD_EPREFIX}"/etc/portage
- mkdir -p "${CHILD_EPREFIX}"/var/log
-)
-eend_exit $?
-
-#
-# create a make.conf and set PORTDIR and PORTAGE_TMPDIR
-#
-ebegin "creating make.conf"
-(
- set -e
- echo "#"
- echo "# The following values where taken from the parent prefix's"
- echo "# environment. Feel free to adopt them as you like."
- echo "#"
- echo "CFLAGS=\"$(portageq envvar CFLAGS)\""
- echo "CXXFLAGS=\"$(portageq envvar CXXFLAGS)\""
- echo "MAKEOPTS=\"$(portageq envvar MAKEOPTS)\""
- niceness=$(portageq envvar PORTAGE_NICENESS || true)
- [[ -n ${niceness} ]] &&
- echo "PORTAGE_NICENESS=\"${niceness}\""
- echo "USE=\"prefix-chaining\""
- echo
- echo "# Mirrors from parent prefix."
- echo "GENTOO_MIRRORS=\"$(portageq envvar GENTOO_MIRRORS || true)\""
- echo
- echo "#"
- echo "# Below comes the chained-prefix setup. Only change things"
- echo "# if you know exactly what you are doing!"
- echo "# by default, only DEPEND is inherited from the parent in"
- echo "# the chain. if you want more, make it a comma seperated"
- echo "# list - like this: DEPEND,RDEPEND,PDEPEN - which would the"
- echo "# all that is possible"
- echo "#"
- echo "PORTDIR=\"$(portageq envvar PORTDIR)\""
- echo "SYNC=\"$(portageq envvar SYNC || true)\""
- if test -z "${PORT_TMPDIR}"; then
- case "${CHILD_PROFILE}" in
- *winnt*) echo "PORTAGE_TMPDIR=/var/tmp" ;;
- *) echo "PORTAGE_TMPDIR=\"${CHILD_EPREFIX}/var/tmp\"" ;;
- esac
- else
- echo "PORTAGE_TMPDIR=\"${PORT_TMPDIR}\""
- fi
- echo "READONLY_EPREFIX=\"${PARENT_EPREFIX}:DEPEND\""
-
- if test "${DO_SOURCES}" == "yes"; then
- # don't fail if nothing found
- for f in /etc/portage/make.conf /etc/make.conf; do
- if [[ -r ${PARENT_EPREFIX}${f} ]]; then
- egrep "^source .*" "${PARENT_EPREFIX}${f}" 2>/dev/null || true
- break;
- fi
- done
- fi
-) > "${CHILD_EPREFIX}"/etc/portage/make.conf
-eend_exit $?
-
-#
-# create the make.profile symlinks.
-#
-ebegin "creating make.profile"
-(
- ln -s "${CHILD_PROFILE}" "${CHILD_EPREFIX}/etc/portage/make.profile"
-)
-eend_exit $?
-
-#
-# adjust permissions of generated files.
-#
-ebegin "adjusting permissions"
-(
- chmod 644 "${CHILD_EPREFIX}"/etc/portage/make.conf
-)
-eend_exit $?
-
-#
-# now merge some basics.
-#
-ebegin "installing required basic packages"
-(
- # this -pv is there to avoid the global update output, which is
- # there on the first emerge run. (thus, just cosmetics).
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -p1qO baselayout-prefix > /dev/null 2>&1
-
- set -e
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -1qO \
- gentoo-functions baselayout-prefix elt-patches gnuconfig prefix-chain-utils
-
- # merge with the parent's chost. this forces the use of the parent
- # compiler, which generally would be illegal - this is an exception.
- # This is required for example on winnt, because the wrapper has to
- # be able to use/resolve symlinks, etc. native winnt binaries miss that
- # ability, but interix binaries don't.
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" CHOST="${PARENT_CHOST}" emerge -1qO gcc-config
-
- # select the chain wrapper profile from gcc-config
- env -i "$(type -P bash)" "${CHILD_EPREFIX}"/usr/bin/gcc-config 1
-
- # do this _AFTER_ selecting the correct compiler!
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -1qO libtool
-)
-eend_exit $?
-
-#
-# wow, all ok :)
-#
-ewarn
-ewarn "all done. don't forget to tune ${CHILD_EPREFIX}/etc/portage/make.conf."
-ewarn "to enter the new prefix, run \"${CHILD_EPREFIX}/startprefix\"."
-ewarn
-EOF
-}
diff --git a/app-portage/prefix-chain-setup/prefix-chain-setup-0.7.ebuild b/app-portage/prefix-chain-setup/prefix-chain-setup-0.7.ebuild
deleted file mode 100644
index 9261c360d302..000000000000
--- a/app-portage/prefix-chain-setup/prefix-chain-setup-0.7.ebuild
+++ /dev/null
@@ -1,238 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit prefix
-
-DESCRIPTION="Chained EPREFIX bootstrapping utility"
-HOMEPAGE="https://prefix.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND="sys-apps/portage[prefix-chaining]"
-
-S="${WORKDIR}"
-
-src_install() {
- eprefixify ${PN}
- sed -e "s,@GENTOO_PORTAGE_CHOST@,${CHOST}," -i ${PN}
- dobin ${PN}
-}
-
-src_unpack() {
- { cat > "${PN}" || die; } <<'EOF'
-#!/usr/bin/env bash
-
-PARENT_EPREFIX="@GENTOO_PORTAGE_EPREFIX@"
-PARENT_CHOST="@GENTOO_PORTAGE_CHOST@"
-CHILD_EPREFIX=
-CHILD_PROFILE=
-DO_MINIMAL=no
-DO_SOURCES=no
-PORT_TMPDIR=
-
-#
-# get ourselfs the functions.sh script for ebegin/eend/etc.
-#
-for f in \
- /lib/gentoo/functions.sh \
- /etc/init.d/functions.sh \
- /sbin/functions.sh \
-; do
- if [[ -r ${PARENT_EPREFIX}${f} ]]; then
- . "${PARENT_EPREFIX}${f}"
- f=found
- break
- fi
-done
-
-if [[ ${f} != found ]]; then
- echo "Cannot find Gentoo functions, aborting." >&2
- exit 1
-fi
-
-for arg in "$@"; do
- case "${arg}" in
- --eprefix=*) CHILD_EPREFIX="${arg#--eprefix=}" ;;
- --profile=*) CHILD_PROFILE="${arg#--profile=}" ;;
- --sources) DO_SOURCES=yes ;;
- --portage-tmpdir=*) PORT_TMPDIR="${arg#--portage-tmpdir=}" ;;
-
- --help)
- einfo "$0 usage:"
- einfo " --eprefix=[PATH] Path to new EPREFIX to create chained to the prefix"
- einfo " where this script is installed (${PARENT_EPREFIX})"
- einfo " --profile=[PATH] The absolute path to the profile to use. This path"
- einfo " must point to a directory within ${PARENT_EPREFIX}"
- einfo " --sources inherit 'source' statements from the parent make.conf"
- einfo " --portage-tmpdir=DIR use DIR as portage temporary directory."
- exit 0
- ;;
- esac
-done
-
-#
-# sanity check of given values
-#
-
-test -n "${CHILD_EPREFIX}" || { eerror "no eprefix argument given"; exit 1; }
-test -d "${CHILD_EPREFIX}" && { eerror "${CHILD_EPREFIX} already exists"; exit 1; }
-test -n "${CHILD_PROFILE}" || { eerror "no profile argument given"; exit 1; }
-test -d "${CHILD_PROFILE}" || { eerror "${CHILD_PROFILE} does not exist"; exit 1; }
-if test -n "${PORT_TMPDIR}"; then
- if ! test -d "${PORT_TMPDIR}"; then
- einfo "creating temporary directory ${PORT_TMPDIR}"
- mkdir -p "${PORT_TMPDIR}"
- fi
-fi
-
-einfo "creating chained prefix ${CHILD_EPREFIX}"
-
-#
-# functions needed below.
-#
-eend_exit() {
- eend $1
- [[ $1 != 0 ]] && exit 1
-}
-
-#
-# create the directories required to bootstrap the least.
-#
-ebegin "creating directory structure"
-(
- set -e
- mkdir -p "${CHILD_EPREFIX}"/etc/portage/profile/use.mask
- mkdir -p "${CHILD_EPREFIX}"/etc/portage/profile/use.force
- mkdir -p "${CHILD_EPREFIX}"/var/log
-)
-eend_exit $?
-
-#
-# create a make.conf and set PORTDIR and PORTAGE_TMPDIR
-#
-ebegin "creating make.conf"
-(
- set -e
- echo "#"
- echo "# The following values where taken from the parent prefix's"
- echo "# environment. Feel free to adopt them as you like."
- echo "#"
- echo "CFLAGS=\"$(portageq envvar CFLAGS)\""
- echo "CXXFLAGS=\"$(portageq envvar CXXFLAGS)\""
- echo "MAKEOPTS=\"$(portageq envvar MAKEOPTS)\""
- niceness=$(portageq envvar PORTAGE_NICENESS || true)
- [[ -n ${niceness} ]] &&
- echo "PORTAGE_NICENESS=\"${niceness}\""
- echo "USE=\"prefix-chain\""
- echo
- echo "# Mirrors from parent prefix."
- echo "GENTOO_MIRRORS=\"$(portageq envvar GENTOO_MIRRORS || true)\""
- echo
- echo "#"
- echo "# Below comes the chained-prefix setup. Only change things"
- echo "# if you know exactly what you are doing!"
- echo "# by default, only DEPEND is inherited from the parent in"
- echo "# the chain. if you want more, make it a comma seperated"
- echo "# list - like this: DEPEND,RDEPEND,PDEPEN - which would the"
- echo "# all that is possible"
- echo "#"
- echo "PORTDIR=\"$(portageq envvar PORTDIR)\""
- echo "SYNC=\"$(portageq envvar SYNC || true)\""
- if test -z "${PORT_TMPDIR}"; then
- case "${CHILD_PROFILE}" in
- *winnt*) echo "PORTAGE_TMPDIR=/var/tmp" ;;
- *) echo "PORTAGE_TMPDIR=\"${CHILD_EPREFIX}/var/tmp\"" ;;
- esac
- else
- echo "PORTAGE_TMPDIR=\"${PORT_TMPDIR}\""
- fi
- echo "READONLY_EPREFIX=\"${PARENT_EPREFIX}:DEPEND\""
-
- if test "${DO_SOURCES}" == "yes"; then
- # don't fail if nothing found
- for f in /etc/portage/make.conf /etc/make.conf; do
- if [[ -r ${PARENT_EPREFIX}${f} ]]; then
- egrep "^source .*" "${PARENT_EPREFIX}${f}" 2>/dev/null || true
- break;
- fi
- done
- fi
-) > "${CHILD_EPREFIX}"/etc/portage/make.conf
-eend_exit $?
-
-ebegin "creating profile/use.mask"
-cat > "${CHILD_EPREFIX}"/etc/portage/profile/use.mask/prefix-chain-setup <<-'EOM'
- # masked in base profile, unmask here
- -prefix-chain
- EOM
-eend_exit $?
-
-ebegin "creating profile/use.force"
-cat > "${CHILD_EPREFIX}"/etc/portage/profile/use.force/prefix-chain-setup <<-'EOM'
- # masked in base profile, force here
- prefix-chain
- EOM
-eend_exit $?
-
-#
-# create the make.profile symlinks.
-#
-ebegin "creating make.profile"
-(
- ln -s "${CHILD_PROFILE}" "${CHILD_EPREFIX}/etc/portage/make.profile"
-)
-eend_exit $?
-
-#
-# adjust permissions of generated files.
-#
-ebegin "adjusting permissions"
-(
- chmod 644 "${CHILD_EPREFIX}"/etc/portage/make.conf
-)
-eend_exit $?
-
-#
-# now merge some basics.
-#
-ebegin "installing required basic packages"
-(
- # this -pv is there to avoid the global update output, which is
- # there on the first emerge run. (thus, just cosmetics).
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -p1qO baselayout-prefix > /dev/null 2>&1
-
- set -e
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -1qO \
- gentoo-functions baselayout-prefix gnuconfig prefix-chain-utils
-
- # merge with the parent's chost. this forces the use of the parent
- # compiler, which generally would be illegal - this is an exception.
- # This is required for example on winnt, because the wrapper has to
- # be able to use/resolve symlinks, etc. native winnt binaries miss that
- # ability, but interix binaries don't.
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" CHOST="${PARENT_CHOST}" emerge -1qO gcc-config
-
- # select the chain wrapper profile from gcc-config
- env -i "$(type -P bash)" "${CHILD_EPREFIX}"/usr/bin/gcc-config 1
-
- # do this _AFTER_ selecting the correct compiler!
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -1qO libtool
-)
-eend_exit $?
-
-#
-# wow, all ok :)
-#
-ewarn
-ewarn "all done. don't forget to tune ${CHILD_EPREFIX}/etc/portage/make.conf."
-ewarn "to enter the new prefix, run \"${CHILD_EPREFIX}/startprefix\"."
-ewarn
-EOF
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index d7065292f3a3..cf80cff55130 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -555,12 +555,6 @@ media-video/episoder
# Requires >=dev-lang/lua-5.3 which is masked
sys-apps/likwid
-# Michael Haubenwallner <haubi@gentoo.org> (25 Mar 2019)
-# Obsolete, in favor of app-portage/prefix-toolkit.
-# Removal in 30 days. Bug #658572
-app-portage/prefix-chain-setup
-sys-apps/prefix-chain-utils
-
# Andreas Sturmlechner <asturm@gentoo.org> (23 Mar 2019)
# Everything breaks again. bug #681336
>=app-text/poppler-0.75.0
diff --git a/sys-apps/prefix-chain-utils/files/prefix-chain-wrapper.in b/sys-apps/prefix-chain-utils/files/prefix-chain-wrapper.in
deleted file mode 100644
index d612cc46bb28..000000000000
--- a/sys-apps/prefix-chain-utils/files/prefix-chain-wrapper.in
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/usr/bin/env bash
-
-if [ -r /cygdrive/. ]; then
- winpath2unix() { cygpath -u "$1"; }
- unixpath2win() { cygpath -w "$1"; }
-fi
-
-link_dirs=()
-opts=()
-chost="@GENTOO_PORTAGE_CHOST@"
-prefix="@GENTOO_PORTAGE_EPREFIX@"
-absprefix=${prefix}
-if [[ ${CHOST} == *"-winnt"* ]]; then
- # we may get called from windows binary, like pkgdata in dev-libs/icu
- # in this case, PATH elements get the "/dev/fs/C/WINDOWS/SUA" prefix
- absprefix=$(winpath2unix "$(unixpath2win "${absprefix}")")
-fi
-[[ $0 == *windres* ]] && mode=compile || mode=link
-orig_args=("$@")
-
-for opt in "$@"; do
- case "$opt" in
- -L) link_dirs=("${link_dirs[@]}" "-L$1"); shift ;;
- -L*) link_dirs=("${link_dirs[@]}" "${opt}") ;;
- *)
- case "${opt}" in
- -v)
- # -v done right: only use mode version if -v is the _only_
- # argument on the command line.
- [[ ${#orig_args[@]} -gt 1 ]] || mode=version
- ;;
- --version) mode=version ;;
- -c|-E|-S) mode=compile ;;
- -print-search-dirs) mode=dirs ;;
- esac
- opts=("${opts[@]}" "${opt}")
- ;;
- esac
-done
-
-save_ifs=$IFS
-IFS=':'
-new_path=
-for p in $PATH; do
- IFS=$save_ifs
- [[ "${p#${absprefix}}" != "${p}" ]] && continue
- if [[ -z "${new_path}" ]]; then
- new_path="${p}"
- else
- new_path="${new_path}:${p}"
- fi
-done
-IFS=$save_ifs
-
-PATH=${new_path}
-
-# toolchain-prefix-wrapper's ld-wrapper understands '-R' for aix and hpux too.
-# parity (winnt) understands -rpath only ...
-case "${chost}" in
-*-winnt*) rpath_opt="-Wl,-rpath," ;;
-*) rpath_opt="-Wl,-R," ;;
-esac
-
-pfx_link=("-L${prefix}/usr/lib" "-L${prefix}/lib")
-pfx_link_r=("${rpath_opt}${prefix}/lib" "${rpath_opt}${prefix}/usr/lib")
-pfx_comp=("-I${prefix}/include" "-I${prefix}/usr/include")
-
-case "$mode" in
-link) exec "$(basename $0)" "${link_dirs[@]}" "${pfx_link[@]}" "${opts[@]}" "${pfx_comp[@]}" "${pfx_link_r[@]}" ;;
-compile) exec "$(basename $0)" "${link_dirs[@]}" "${opts[@]}" "${pfx_comp[@]}" ;;
-version) exec "$(basename $0)" "${orig_args[@]}" ;;
-dirs)
- "$(basename $0)" "${orig_args[@]}" | while read line; do
- if [[ "${line}" == "libraries: ="* ]]; then
- echo "libraries: =${prefix}/usr/lib:${prefix}/lib:${line#"libraries: ="}"
- else
- echo "${line}"
- fi
- done
- ;;
-*) echo "cannot infer $0's mode from comamnd line arguments"; exit 1 ;;
-esac
-
diff --git a/sys-apps/prefix-chain-utils/files/startprefix.in b/sys-apps/prefix-chain-utils/files/startprefix.in
deleted file mode 100644
index 3882ffe14a9c..000000000000
--- a/sys-apps/prefix-chain-utils/files/startprefix.in
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/usr/bin/env bash
-
-if [[ -r "@GENTOO_PORTAGE_EPREFIX@"/lib/gentoo/functions.sh ]]; then
- . "@GENTOO_PORTAGE_EPREFIX@"/lib/gentoo/functions.sh
-elif [[ -r "@GENTOO_PORTAGE_EPREFIX@"/etc/init.d/functions.sh ]]; then
- . "@GENTOO_PORTAGE_EPREFIX@"/etc/init.d/functions.sh
-elif [[ -r "@GENTOO_PORTAGE_EPREFIX@"/sbin/functions.sh ]]; then
- . "@GENTOO_PORTAGE_EPREFIX@"/sbin/functions.sh
-fi
-
-einfo "entering chained prefix @GENTOO_PORTAGE_EPREFIX@ ..."
-
-# inform profiles very early of us beeing interactive (or at least,
-# we will _start_ an interactive shell, so we want the according bits.)
-set -i
-
-. "@GENTOO_PORTAGE_EPREFIX@"/etc/profile
-
-# if there is no local portage, foreign portage instances need to know
-# where to merge to - and thus we need to set EPREFIX.
-# the other way round, if there is a local portage, EPREFIX may not
-# point anywhere else than to our local EPREFIX or be unset...
-
-# DISABLED: this is done by etc/profile now, to be able to start a
-# prefix environment by sourcing etc/profile.
-
-#if [[ -x "@GENTOO_PORTAGE_EPREFIX@"/usr/bin/emerge ]]; then
-# if [[ -n "${EPREFIX}" ]] && [[ "${EPREFIX}" != "@GENTOO_PORTAGE_EPREFIX@" ]]; then
-# ewarn "EPREFIX is set. this will render portage unusable, unsetting"
-# unset EPREFIX
-# fi
-#else
-# export EPREFIX="@GENTOO_PORTAGE_EPREFIX@"
-#fi
-
-# a common problem: the child has no less installed, but baselayout insists
-# on setting PAGER to EPREFIX/usr/bin/less. everything gets back to normal
-# when unsetting PAGER in this case.
-if [[ ! -x "${PAGER}" ]]; then
- unset PAGER
-fi
-
-bash --noprofile
-einfo "leaving chained prefix @GENTOO_PORTAGE_EPREFIX@ ..."
-
diff --git a/sys-apps/prefix-chain-utils/metadata.xml b/sys-apps/prefix-chain-utils/metadata.xml
deleted file mode 100644
index d33cce94b0d4..000000000000
--- a/sys-apps/prefix-chain-utils/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>prefix@gentoo.org</email>
- <name>Gentoo Prefix</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r7.ebuild b/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r7.ebuild
deleted file mode 100644
index b447752a1536..000000000000
--- a/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r7.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit prefix
-
-DESCRIPTION="Chained EPREFIX utilities and wrappers"
-HOMEPAGE="https://dev.gentoo.org/~haubi"
-SRC_URI=""
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~ppc-aix ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
-IUSE=""
-
-DEPEND=""
-RDEPEND="sys-devel/gcc-config"
-
-src_unpack() {
- mkdir -p "${S}"
-}
-
-src_install() {
- cp "${FILESDIR}"/*.in "${T}"
- eprefixify "${T}"/*.in
-
- for x in "${T}"/*.in; do
- mv ${x} ${x%.in}
- done
-
- # install toolchain wrapper.
- wrapperdir=/usr/${CHOST}/gcc-bin/${CHOST}-prefix-chain-wrapper/${PV}
- wrappercfg=${CHOST}-prefix-chain-wrapper-${PV}
-
- exeinto $wrapperdir
- sed -i -e "s,@GENTOO_PORTAGE_CHOST@,${CHOST},g" "${T}"/prefix-chain-wrapper
- doexe "${T}"/prefix-chain-wrapper
-
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-gcc
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-g++
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-cpp
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-c++
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-windres
-
- dosym $wrapperdir/${CHOST}-gcc $wrapperdir/gcc
- dosym $wrapperdir/${CHOST}-g++ $wrapperdir/g++
- dosym $wrapperdir/${CHOST}-cpp $wrapperdir/cpp
- dosym $wrapperdir/${CHOST}-c++ $wrapperdir/c++
- dosym $wrapperdir/${CHOST}-windres $wrapperdir/windres
-
- # LDPATH is required to keep gcc-config happy :(
- cat > "${T}"/$wrappercfg <<EOF
-GCC_PATH="${EPREFIX}/$wrapperdir"
-LDPATH="${EPREFIX}/$wrapperdir"
-EOF
-
- insinto /etc/env.d/gcc
- doins "${T}"/$wrappercfg
-
- # install startprefix script.
- exeinto /
- doexe "${T}"/startprefix
-}