summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/nodejs/nodejs-12.22.1-r1.ebuild10
-rw-r--r--net-libs/nodejs/nodejs-14.16.1-r1.ebuild10
-rw-r--r--net-libs/nodejs/nodejs-16.0.0-r1.ebuild10
3 files changed, 27 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
index aa8392c1ff25..52bbbaf58628 100644
--- a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
@@ -59,7 +59,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
index 02e8c08318b3..0cc7ac183eeb 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
@@ -54,7 +54,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}
diff --git a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
index e9e14a673451..e9b170f229d1 100644
--- a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
+++ b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
@@ -53,7 +53,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}