summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/blessed/Manifest1
-rw-r--r--dev-python/blessed/blessed-1.19.1.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/blessed/Manifest b/dev-python/blessed/Manifest
index 517416a92de1..496a65259fce 100644
--- a/dev-python/blessed/Manifest
+++ b/dev-python/blessed/Manifest
@@ -1,2 +1 @@
-DIST blessed-1.19.1.tar.gz 6653802 BLAKE2B 5755efde3c203ab21a8994e29c55cdaace1cca772c9cdee4343562bb8ee4f9ffdee97d9131646d8385ef7e46664d23723ba46a3807d85623d9512ca40c7c4002 SHA512 0d899c42d7c6246362081bdc5d7dd2fcb13209fe0cee7e5a4fa342bdaf16a5cc21ab7e402bc5287ab1239f7e3afb02381e0e57e2d6111b80fe3c52b92cfa0f84
DIST blessed-1.20.0.tar.gz 6655612 BLAKE2B 10523940ac2fe528487f2d1d68d9f38782ec260f1f42735940219d37d4b4dbaef2fd4ca63d753780123d54ae39ab04652d2c6ba8f3323c621a2206b0a706f6e0 SHA512 8567ff1c55f68ad99c6c524edbf8ee57813d23d885dcb372767debc76bc2d75642c2b0491e1ed05460f023c28403b5dabb13769dea101a1c6e3156c82e0d0355
diff --git a/dev-python/blessed/blessed-1.19.1.ebuild b/dev-python/blessed/blessed-1.19.1.ebuild
deleted file mode 100644
index 6dc171a28ffa..000000000000
--- a/dev-python/blessed/blessed-1.19.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="Library for making terminal apps using colors, keyboard input and positioning"
-HOMEPAGE="https://github.com/jquast/blessed"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~riscv x86"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Skip those extensions as they don't have a Gentoo package
- # Remove calls to scripts that generate rst files because they
- # are not present in the tarball
- sed -e '/sphinxcontrib.manpage/d' -e '/sphinx_paramlinks/d' \
- -e '/^for script in/,/runpy.run_path/d' \
- -i docs/conf.py || die
- # Requires pytest-xdist and has no value for us
- sed -i '/^looponfailroots =/d' tox.ini || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # COLORTERM must not be truecolor
- # See https://github.com/jquast/blessed/issues/162
- # Ignore coverage options
- COLORTERM= epytest --override-ini="addopts="
-}