summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
index 7b821afa63e4..03a121ac68a1 100644
--- a/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Tool for launching commands on keystrokes"
SRC_URI="https://www.nongnu.org/${PN}/${P}.tar.gz"
HOMEPAGE="https://www.nongnu.org/xbindkeys/xbindkeys.html"
@@ -12,10 +14,6 @@ SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="guile tk"
-PATCHES=(
- "${FILESDIR}/xbindkeys-1.8.7-guile3.patch"
-)
-
RDEPEND="
x11-libs/libX11
guile? ( >=dev-scheme/guile-1.8.4:=[deprecated] )
@@ -25,9 +23,19 @@ DEPEND="
${RDEPEND}
x11-base/xorg-proto
"
-DOCS="
- AUTHORS BUGS ChangeLog README TODO xbindkeysrc
-"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO xbindkeysrc )
+
+PATCHES=(
+ "${FILESDIR}/xbindkeys-1.8.7-guile3.patch"
+)
+
+src_prepare() {
+ default
+
+ # For guile patch, touches m4/
+ eautoreconf
+}
src_configure() {
econf \