summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/recaptcha/Manifest1
-rw-r--r--dev-php/recaptcha/metadata.xml8
-rw-r--r--dev-php/recaptcha/recaptcha-1.1.2.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/recaptcha/Manifest b/dev-php/recaptcha/Manifest
new file mode 100644
index 000000000000..476cd9900c9e
--- /dev/null
+++ b/dev-php/recaptcha/Manifest
@@ -0,0 +1 @@
+DIST recaptcha-1.1.2.tar.gz 12624 SHA256 1a319620ee05706cc7c8cb6a6a2e83271b3f74788eda26c26ccb0ae1fa2e1612 SHA512 e9d24aec9a51e14a2122e072adf35b96acb490a6f255abc0835bbc9bc2946bc0aceb92ba270344c83743692fc4a673271ba7e6fa7f32f62132c960a1a5cc4ab5 WHIRLPOOL e090ae43fe6702d97e3667aab8d0e3c68d3fba13838b0e7f13be86f2304949cf8027e49819f6c1f09345b923106e6f6ba2ee9a72ea3ea77d4935a56e66117c84
diff --git a/dev-php/recaptcha/metadata.xml b/dev-php/recaptcha/metadata.xml
new file mode 100644
index 000000000000..df7fdbeaf2b3
--- /dev/null
+++ b/dev-php/recaptcha/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/recaptcha/recaptcha-1.1.2.ebuild b/dev-php/recaptcha/recaptcha-1.1.2.ebuild
new file mode 100644
index 000000000000..67be64d1f732
--- /dev/null
+++ b/dev-php/recaptcha/recaptcha-1.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="PHP client library for Google's reCAPTCHA service"
+HOMEPAGE="https://github.com/google/recaptcha"
+SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php"
+
+src_install(){
+ insinto "/usr/share/php/${PN}"
+ doins -r src/autoload.php src/ReCaptcha
+ dodoc CONTRIBUTING.md README.md
+ use examples && dodoc -r examples
+}
+
+src_test(){
+ phpunit || die "test suite failed"
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/autoload.php'),"
+ elog "and then use the ${PN} class normally. Most of the examples in"
+ elog "the documentation should work without further modification."
+}