summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/phpsysinfo/Manifest1
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.3.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/Manifest b/www-apps/phpsysinfo/Manifest
index 4e88f449592b..3892bbe79f21 100644
--- a/www-apps/phpsysinfo/Manifest
+++ b/www-apps/phpsysinfo/Manifest
@@ -1 +1,2 @@
DIST phpsysinfo-3.3.1.tar.gz 866981 BLAKE2B 9dcaba2bd1b4faa79fe12a2c50dbc767953cf98d45801ca6bc8398eb625b93ebc56356db0f6e05422dd665d8c6e88cb831b4288a5f0190f3c113c1171ea81def SHA512 7b8e0c469651c878b2dcc37189be7b592be5bde4ece38e0aec21afa5a422286b4c6a555bbafc4b7a2eb19e1c2afdac80fddcf03b41084f9da02fb3c92c7242b5
+DIST phpsysinfo-3.3.2.tar.gz 891158 BLAKE2B 40428647a502f9861f89a490a10e95bef0fdf306d2ee27507b4f396ee7371ca3d75b7259db53b8501b127fb525dce283cb8c73e50172b5b2a78fc490fc7f658a SHA512 33f76436d6ba1aa76a4c7e7dba84f5d4bf458b505df47d65ff9f1ffecc4db48a853c9cdb8583019e70c4d0b54c184ae6d48968f3ed820a711804095a5fc31b07
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.3.2.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.3.2.ebuild
new file mode 100644
index 000000000000..4861a565e05c
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.3.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils webapp
+
+DESCRIPTION="A customizable PHP script that displays information about your system nicely"
+HOMEPAGE="https://rk4an.github.com/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore .travis.yml || die
+
+ mv phpsysinfo.ini{.new,} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ optfeature "showing disk temperatures." app-admin/hddtemp
+ optfeature "showing system uptime." app-misc/uptimed
+ optfeature "showing snmp statistics." net-analyzer/net-snmp
+ optfeature "showing iptables rules." net-firewall/iptables
+ optfeature "showing ipmi sensors." sys-apps/ipmitool
+ optfeature "showing ipmi sensors." sys-apps/ipmiutil
+ optfeature "showing system sensors." sys-apps/lm-sensors
+ optfeature "showing s.m.a.r.t. health." sys-apps/smartmontools
+ optfeature "showing lsi raid controller health." sys-block/megactl
+ optfeature "showing fake raid statistics." sys-fs/dmraid
+ optfeature "showing software raid statistics." sys-fs/mdadm
+ optfeature "showing quota information." sys-fs/quota
+ optfeature "showing ipmi sensors." sys-libs/freeipmi
+ optfeature "showing apc ups statistics." sys-power/apcupsd
+ optfeature "showing ups statistics." sys-power/nut
+}