summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/psinfo/psinfo-0.12-r1.ebuild1
-rw-r--r--sys-process/psinfo/psinfo-0.12-r2.ebuild24
2 files changed, 24 insertions, 1 deletions
diff --git a/sys-process/psinfo/psinfo-0.12-r1.ebuild b/sys-process/psinfo/psinfo-0.12-r1.ebuild
index fdf62188a826..033fcddb450b 100644
--- a/sys-process/psinfo/psinfo-0.12-r1.ebuild
+++ b/sys-process/psinfo/psinfo-0.12-r1.ebuild
@@ -15,7 +15,6 @@ LICENSE="GPL-2"
PATCHES=(
"${FILESDIR}/${P}-asneeded.patch"
- "${FILESDIR}/${P}-char.patch"
)
src_prepare() {
diff --git a/sys-process/psinfo/psinfo-0.12-r2.ebuild b/sys-process/psinfo/psinfo-0.12-r2.ebuild
new file mode 100644
index 000000000000..fdf62188a826
--- /dev/null
+++ b/sys-process/psinfo/psinfo-0.12-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Process information and statistics using the kernel /proc interface"
+HOMEPAGE="http://www.ward.nu/computer/psinfo/"
+SRC_URI="http://www.ward.nu/computer/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+
+PATCHES=(
+ "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${P}-char.patch"
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}