summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Net-RawIP/Net-RawIP-0.250.0-r2.ebuild20
-rw-r--r--dev-perl/Net-RawIP/files/Net-RawIP-0.25-no-network-tests.patch25
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Net-RawIP/Net-RawIP-0.250.0-r2.ebuild b/dev-perl/Net-RawIP/Net-RawIP-0.250.0-r2.ebuild
new file mode 100644
index 000000000000..7705fe8901e6
--- /dev/null
+++ b/dev-perl/Net-RawIP/Net-RawIP-0.250.0-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SAPER
+DIST_VERSION=0.25
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Raw IP packets manipulation Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+PERL_RM_FILES=( "t/90-pod.t" "t/91-pod-coverage.t" "t/99-critic.t" )
+PATCHES=("${FILESDIR}/${PN}-0.25-no-network-tests.patch")
diff --git a/dev-perl/Net-RawIP/files/Net-RawIP-0.25-no-network-tests.patch b/dev-perl/Net-RawIP/files/Net-RawIP-0.25-no-network-tests.patch
new file mode 100644
index 000000000000..8eddbdd9a1d0
--- /dev/null
+++ b/dev-perl/Net-RawIP/files/Net-RawIP-0.25-no-network-tests.patch
@@ -0,0 +1,25 @@
+From ba688d50d538e571f124ebbfd8b8a8402c50fdfb Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 15 Dec 2017 20:36:58 +1300
+Subject: Disable world-wide DNS lookups when NO_NETWORK_TESTING
+
+---
+ t/iflist.t | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/t/iflist.t b/t/iflist.t
+index 0982c77..d8026cd 100644
+--- a/t/iflist.t
++++ b/t/iflist.t
+@@ -32,6 +32,8 @@ BEGIN { $tests += 4 } SKIP: {
+ like( $@, qr{host_to_ip: failed}, "rdev('ab cd') => undef" );
+
+ # this test will fail if there is not network connection
++ skip "NO_NETWORK_TESTING=1", 1
++ if 1 eq ( $ENV{NO_NETWORK_TESTING} || '0' );
+ $r = rdev('cisco.com');
+ ok( $r, "rdev('cisco.com') => $r" );
+ }
+--
+2.15.1
+