summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/julius/Manifest1
-rw-r--r--games-strategy/julius/files/90julius.sh2
-rw-r--r--games-strategy/julius/julius-1.4.1.ebuild42
-rw-r--r--games-strategy/julius/metadata.xml25
4 files changed, 70 insertions, 0 deletions
diff --git a/games-strategy/julius/Manifest b/games-strategy/julius/Manifest
new file mode 100644
index 000000000000..1e31cd76e509
--- /dev/null
+++ b/games-strategy/julius/Manifest
@@ -0,0 +1 @@
+DIST julius-1.4.1.tar.gz 8592785 BLAKE2B 8eb91522fccdee33600b02de766727beb19f138c0f695eb92aaa77ea2f25ec293906d0c75d31d42159097a12317ba38b22c01e7edf722670f51fe56d625d9ae7 SHA512 8488cee4a229299fd771f7ebddf076888b2e11458b2edbb6058b29b1f7e79d372ec2f913df3afacd8191551ba692a900508e64661ead1029916e28f356f79f7b
diff --git a/games-strategy/julius/files/90julius.sh b/games-strategy/julius/files/90julius.sh
new file mode 100644
index 000000000000..e88111f8994b
--- /dev/null
+++ b/games-strategy/julius/files/90julius.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/env bash
+alias julius-game='julius-game ~/.cache/julius/app'
diff --git a/games-strategy/julius/julius-1.4.1.ebuild b/games-strategy/julius/julius-1.4.1.ebuild
new file mode 100644
index 000000000000..06b33f139f83
--- /dev/null
+++ b/games-strategy/julius/julius-1.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Feature-faithful open source re-implementation of Caesar III"
+HOMEPAGE="https://github.com/bvschaik/julius"
+SRC_URI="https://github.com/bvschaik/julius/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,video,sound]
+ media-libs/sdl2-mixer
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /etc/profile.d
+ doins "${FILESDIR}"/90julius.sh
+ cmake_src_install
+ mv "${ED}"/usr/bin/julius "${ED}"/usr/bin/julius-game ||
+ die "Failed to rename executable (required as per conflict with app-accessibility/julius)"
+}
+
+pkg_postinst() {
+ ewarn "Julius requires you to download the original Caesar 3 resources."
+ ewarn
+ ewarn "You need to obtain these files from a vendor of the proprietary software."
+ ewarn "You will then need to copy the 'app' directory into '~/.cache/julius/'."
+ ewarn "One way to obtain this directory is to download the GOG Cesar 3 edition."
+ ewarn "You can then produce this directory by running:"
+ ewarn " innoextract -m setup_caesar3_2.0.0.9.exe"
+ ewarn
+ ewarn "Lastly, run 'source /etc/profile' to refresh your environment and be able"
+ ewarn "to start the game directly by running 'julius-game' in the command line."
+}
diff --git a/games-strategy/julius/metadata.xml b/games-strategy/julius/metadata.xml
new file mode 100644
index 000000000000..88f523bf415c
--- /dev/null
+++ b/games-strategy/julius/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>chr@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <longdescription lang="en">
+ The aim of this project is to create an open-source version of
+ Caesar 3, with the same logic as the original, but with some UI
+ enhancements, that is able to be played on multiple platforms.
+ The same logic means that the saved games are 100% compatible,
+ and any gameplay bugs present in the original Caesar 3 game will
+ also be present in Julius. It is meant as a drop-in replacement
+ for Caesar 3, with the same look and feel, so there will be no
+ major UI changes.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bvschaik/julius</remote-id>
+ </upstream>
+</pkgmetadata>