summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Conf-Libconfig/Conf-Libconfig-0.100.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Conf-Libconfig/Conf-Libconfig-0.100.0-r1.ebuild b/dev-perl/Conf-Libconfig/Conf-Libconfig-0.100.0-r1.ebuild
new file mode 100644
index 000000000000..6d48e73fb60e
--- /dev/null
+++ b/dev-perl/Conf-Libconfig/Conf-Libconfig-0.100.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CNANGEL
+DIST_VERSION="0.100"
+
+inherit perl-module
+
+DESCRIPTION="Perl extension for libconfig"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PERL_RM_FILES=(
+ "t/boilerplate.t"
+ "t/pod-coverage.t"
+ "t/pod-spell.t"
+ "t/pod.t"
+)
+RDEPEND="
+ dev-libs/libconfig
+ virtual/perl-XSLoader
+"
+DEPEND="
+ dev-libs/libconfig
+"
+BDEPEND="${RDEPEND}
+ dev-perl/ExtUtils-PkgConfig
+ test? (
+ >=dev-perl/Test-Exception-0.430.0
+ >=dev-perl/Test-Deep-1.127.0
+ >=dev-perl/Test-Warn-0.320.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}