summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycups/Manifest1
-rw-r--r--dev-python/pycups/pycups-1.9.72.ebuild50
-rw-r--r--dev-python/pycups/pycups-1.9.73.ebuild54
3 files changed, 0 insertions, 105 deletions
diff --git a/dev-python/pycups/Manifest b/dev-python/pycups/Manifest
index a36f1f23bdaa..e30fc7d69009 100644
--- a/dev-python/pycups/Manifest
+++ b/dev-python/pycups/Manifest
@@ -1,2 +1 @@
-DIST pycups-1.9.72.tar.bz2 52687 BLAKE2B 37d2bf2afc71b4feabbd5aac0c4dab49142a580b0b82d337709ef79a666ea2ad7942072f4f09923099626103a67f6b9a08a7972481ea28f7a88e13118e194d4d SHA512 db8b06378bf398073e34c89d62aa64cc8e56e93553346484c2e5dd67d046a3aa2f44020b68a7d479203fb2eeba005f8860ad4cebf72f8d7aa9aa15952a36d816
DIST pycups-1.9.73.tar.bz2 52732 BLAKE2B a6c9750970548ba85cdef4041f716491e9b0cf4273cb5381bca8e57deab457affaa62eccf74d36eb3f8b047e5142c952e56e7e624f85ed7959a769f568824f26 SHA512 ee893d64f1645b71805ac358c4a3cc594f6285f04272ff0558aa60cbc90fafdbac30b623ffcc3a6b739218d9fd7a6a6e1d8cb186a5582f2cc30a518ed4dde810
diff --git a/dev-python/pycups/pycups-1.9.72.ebuild b/dev-python/pycups/pycups-1.9.72.ebuild
deleted file mode 100644
index c7002ddb5e03..000000000000
--- a/dev-python/pycups/pycups-1.9.72.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the CUPS API"
-HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86"
-SLOT="0"
-IUSE="doc examples"
-
-RDEPEND="
- net-print/cups
-"
-DEPEND="${RDEPEND}"
-
-# epydoc kinda sucks and supports python2 only (it's dead too),
-# and since we're dealing with a binary module we need exact version
-# match. therefore, docbuilding *requires* any python2 being enabled.
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc[$(python_gen_usedep 'python2*')] )
-"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-python_compile_all() {
- if use doc; then
- # we can't use Makefile since it relies on hardcoded paths
- epydoc -o html --html cups || die "doc build failed"
- fi
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/ )
- use examples && local EXAMPLES=( examples/ )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pycups/pycups-1.9.73.ebuild b/dev-python/pycups/pycups-1.9.73.ebuild
deleted file mode 100644
index 4701a3f40c30..000000000000
--- a/dev-python/pycups/pycups-1.9.73.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the CUPS API"
-HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86"
-SLOT="0"
-IUSE="doc examples"
-
-RDEPEND="
- net-print/cups
-"
-DEPEND="${RDEPEND}"
-
-# epydoc kinda sucks and supports python2 only (it's dead too),
-# and since we're dealing with a binary module we need exact version
-# match. therefore, docbuilding *requires* any python2 being enabled.
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc[$(python_gen_usedep 'python2*')] )
-"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
-}
-
-python_compile_all() {
- if use doc; then
- # we can't use Makefile since it relies on hardcoded paths
- epydoc -o html --html cups || die "doc build failed"
- fi
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/ )
- use examples && local EXAMPLES=( examples/ )
-
- distutils-r1_python_install_all
-}