summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/wcmatch/Manifest1
-rw-r--r--dev-python/wcmatch/wcmatch-8.4.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index 106502d62cf3..56830604ca0d 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1 +1,2 @@
+DIST wcmatch-8.4.1.gh.tar.gz 117065 BLAKE2B 6528170503507aa9742a0e0878f7cfe2586408471acde82ffbf1011fbf48cbed6a45d580436cb6a63a54a81d1c237544a48112eb4c06f923752eb09521d7f8a5 SHA512 6bc8d59b678a40e28eee7816f3b447fe3396f52e982df8e0b5e26472b4ffd1342f58edc41850386954783e6d07f1d66d9372cc1495f048b9a542b572b1d8e20f
DIST wcmatch-8.4.gh.tar.gz 116596 BLAKE2B cdfbc243fa62f4854490510a563163f99dac09eed16248fa7a72d0a2a7b96484fab4edf3ba497e96a46dca1f734b9c1b098da4d71784775f51b48fcfa5b8a24c SHA512 92478a769be129f9997ef75a384b9978d0647bbd7f2212aa058f1438e698a0a77d069871daf20889455f6e9bb73266d4e312f29f61c704a708fa48fa565d7614
diff --git a/dev-python/wcmatch/wcmatch-8.4.1.ebuild b/dev-python/wcmatch/wcmatch-8.4.1.ebuild
new file mode 100644
index 000000000000..42be0b6abeee
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.4.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs_pymdownx_material_extras-2.0
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/
+"
+SRC_URI="
+ https://github.com/facelessuser/wcmatch/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/bracex-2.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}