summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/configshell-fb/Manifest1
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.27.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 34a2321ea9c0..8d903ebc96a8 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1 +1,2 @@
DIST configshell-fb-1.1.25.tar.gz 56900 BLAKE2B 00f16c401a87cde0e70730ec74fe5885af3ebf22c3745851661fea7de874f5609c49e0b7c521c5d3db16eec903e0f24331816acc8e19a080043e8399c98bd18f SHA512 338eee8eb7b0fad533b739bb0c9460757cdb90103c44c37568dd86158431b67e1b0ab050afe2670abbba96c5d8c18db9b107d9f7650937a2be7f53fad26efed3
+DIST configshell-fb-1.1.27.tar.gz 57174 BLAKE2B 4f1f4dd6b641fc5843956b3d88f43456f326af16799b770b1224ba029903fb6bfb291101ae780f48fa126c9e5482b95e5e545121a11afc9d8535dd23be3445c1 SHA512 53d81b939f393f88141f2c158295a5297850e2a908b6124d085b2ae185a2093b877bffb0536a195b2743057bbd3131c75daeb90a4b83b6305baa89463e30c685
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.27.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.27.ebuild
new file mode 100644
index 000000000000..4a0c0dc14cb1
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.27.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]"