summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/git-publish/Manifest1
-rw-r--r--dev-vcs/git-publish/git-publish-1.7.0.ebuild43
-rw-r--r--dev-vcs/git-publish/metadata.xml17
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-vcs/git-publish/Manifest b/dev-vcs/git-publish/Manifest
new file mode 100644
index 000000000000..09e46d1b96d0
--- /dev/null
+++ b/dev-vcs/git-publish/Manifest
@@ -0,0 +1 @@
+DIST git-publish-1.7.0.tar.gz 21569 BLAKE2B 1438e5018ebe7d258fee2527597e56080b574765a87b03d814b6d0d41c68397cba6099866382e9f2c560d8bab58214fb9e5f54f0127433917178337df81ff789 SHA512 dbf343e0284c52edd42ba8d844a9db90810ddd02e7a98bcd1c2af72cd9f5242e9c0a9ea921edf47583bfe05943288286e57a018a7a6b2dcf25bae4f663225025
diff --git a/dev-vcs/git-publish/git-publish-1.7.0.ebuild b/dev-vcs/git-publish/git-publish-1.7.0.ebuild
new file mode 100644
index 000000000000..7a000d781109
--- /dev/null
+++ b/dev-vcs/git-publish/git-publish-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit python-single-r1
+
+DESCRIPTION="Tool for preparing and storing patch revisions as git tag"
+HOMEPAGE="https://github.com/stefanha/git-publish"
+SRC_URI="https://github.com/stefanha/git-publish/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+man"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-vcs/git
+"
+BDEPEND="${PYTHON_DEPS}
+ man? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+ python_fix_shebang git-publish
+}
+
+src_compile() {
+ if use man; then
+ pod2man --center "git-publish Documentation" --release "${PV}" \
+ git-publish.pod git-publish.1 || die
+ fi
+}
+
+src_install() {
+ dobin git-publish
+ use man && doman git-publish.1
+ insinto /usr/share/${PN}/hooks
+ doins hooks/pre-publish-send-email.example
+}
diff --git a/dev-vcs/git-publish/metadata.xml b/dev-vcs/git-publish/metadata.xml
new file mode 100644
index 000000000000..b97d2e99f3b7
--- /dev/null
+++ b/dev-vcs/git-publish/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ git-publish prepares patches and stores them as git tags for future reference.
+ It works with individual patches as well as patch series. Revision numbering
+ is handled automatically.
+ </longdescription>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">stefanha/git-publish</remote-id>
+ </upstream>
+</pkgmetadata>