summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/wcd/Manifest1
-rw-r--r--app-misc/wcd/files/wcd-6.0.3-doc-path.patch7
-rw-r--r--app-misc/wcd/files/wcd-6.0.4-gentoo.patch2
-rw-r--r--app-misc/wcd/metadata.xml5
-rw-r--r--app-misc/wcd/wcd-6.0.5.ebuild49
5 files changed, 59 insertions, 5 deletions
diff --git a/app-misc/wcd/Manifest b/app-misc/wcd/Manifest
index b3fbcd9285ec..7e94b7947904 100644
--- a/app-misc/wcd/Manifest
+++ b/app-misc/wcd/Manifest
@@ -1 +1,2 @@
DIST wcd-6.0.4.tar.gz 935815 BLAKE2B 00ec281890fe363258e0c847460ad9067f1c14409e64dfde239340ecf4f711af2047a8a1da226d4d17797e2b7452a4cd5aa65a0fcedcc2c172378d35a18a4a20 SHA512 afec27c0ca4cf7c7d24399f1f23c69ee765d57b449179696be5da82bcd6b146156254d9d1264e9c1f4905d5c117c7ac935a372aea25fa539b76c9bc866640daa
+DIST wcd-6.0.5.tar.gz 1130436 BLAKE2B 65ba203f42ada8657ca11ec15a3a76d31523b0dc388415fbbc58e710e2ffec5b96f85d962ddcdb07b7749395223c64e367402106aa7d5a8910f63d09ffac004c SHA512 ac3fc0690e2011ab3a6863f075859a53887a7826b456f35b13421f8c3ed23e0a4665d9641163a2142ffae18b26379b2dbefab75a124c556bd0103522aaeb3d13
diff --git a/app-misc/wcd/files/wcd-6.0.3-doc-path.patch b/app-misc/wcd/files/wcd-6.0.3-doc-path.patch
index 16e850a8baac..7fc8bf310ecc 100644
--- a/app-misc/wcd/files/wcd-6.0.3-doc-path.patch
+++ b/app-misc/wcd/files/wcd-6.0.3-doc-path.patch
@@ -1,8 +1,9 @@
Install docs into /usr/share/doc/wcd-${PVR}.
-diff -Nuar a/src/Makefile b/src/Makefile
---- a/src/Makefile 2019-08-14 10:07:15.000000000 +0000
-+++ b/src/Makefile 2021-10-23 17:10:17.000000000 +0000
+Bug: https://bugs.gentoo.org/802696
+
+--- a/src/Makefile
++++ b/src/Makefile
@@ -61,7 +61,7 @@
datarootdir = $(prefix)/share
datadir = $(datarootdir)
diff --git a/app-misc/wcd/files/wcd-6.0.4-gentoo.patch b/app-misc/wcd/files/wcd-6.0.4-gentoo.patch
index 80fa5dc83ec4..4a465e16b9c8 100644
--- a/app-misc/wcd/files/wcd-6.0.4-gentoo.patch
+++ b/app-misc/wcd/files/wcd-6.0.4-gentoo.patch
@@ -77,8 +77,6 @@ Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
%.o: %.c
$(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@
-diff --git a/src/Makefile b/src/Makefile
-index fc317de..c5cff96 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -359,7 +359,7 @@ endif
diff --git a/app-misc/wcd/metadata.xml b/app-misc/wcd/metadata.xml
index df1ea8d84522..bd65558b9507 100644
--- a/app-misc/wcd/metadata.xml
+++ b/app-misc/wcd/metadata.xml
@@ -5,4 +5,9 @@
<email>shell-tools@gentoo.org</email>
<name>Gentoo Shell Tools Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="sourceforge">wcd</remote-id>
+ <bugs-to>https://sourceforge.net/p/wcd/bugs/</bugs-to>
+ <changelog>https://waterlan.home.xs4all.nl/wcd/doc/whatsnew.txt</changelog>
+ </upstream>
</pkgmetadata>
diff --git a/app-misc/wcd/wcd-6.0.5.ebuild b/app-misc/wcd/wcd-6.0.5.ebuild
new file mode 100644
index 000000000000..5ccc91c1fbb2
--- /dev/null
+++ b/app-misc/wcd/wcd-6.0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Wherever Change Directory"
+HOMEPAGE="https://waterlan.home.xs4all.nl/wcd.html"
+SRC_URI="https://waterlan.home.xs4all.nl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls unicode"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)?]
+ unicode? ( dev-libs/libunistring:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/ghostscript-gpl
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.4-gentoo.patch
+ "${FILESDIR}"/${PN}-6.0.3-doc-path.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ cd src || die
+ local mycompile="LFS=1"
+ use nls || mycompile+=" ENABLE_NLS="
+ use unicode || mycompile+=" UCS= UNINORM="
+ emake ${mycompile}
+}
+
+src_install() {
+ cd src || die
+ local DOCS=( ../README.txt )
+ default
+ emake DESTDIR="${ED}" DOTWCD=1 install-profile sysconfdir="/etc"
+}