summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.24.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 74102c584bd3..af41a4f3cc82 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.24.5.tar.xz 24708 BLAKE2B e6937ec76b6cadff437c77eaceb075d7050e6d3581e64b66c1a07491352e335e63dc58b6655da6f5532919295bfad0e13da6855370b4c0a3c1eacb9698dc1759 SHA512 e4d7358eb213105a4e479eb3c9d229a87d86c4ebda199f486f9952f81dc1e91b43ba30d834907586f9badbb7e2933e44af5713119caa2e3bc060f16936e9a457
+DIST ksshaskpass-5.24.6.tar.xz 24712 BLAKE2B b0656c01d4bf3c59461d001c8d7055e4705d9b74f9dba192562f83128d189c07e3b0bba30ef340123092c83100d1ea264ade2583be2219b23a446b4fde70d031 SHA512 6c7af2e9f322a03c9426f4d5ee25b5d7a7f29cc68c6351eb608db43ea61dc5dae26ff43753ea9dae500a5498b56accea750bdae8ed36f37a43da3e302c646afb
DIST ksshaskpass-5.25.2.tar.xz 24908 BLAKE2B 3103df99571277a9b2dbff8426e2d62a48f6fdc281bc22041edac173c3dc75cab28cb9ef67a6a46de7a3e27031c48a530ade23da278021a90f7c1e3b4bdc69d5 SHA512 1ac15dba4a6263a45d9a5468029b57405764702fa4facc8f3eebf9c09f051e60cfa9cbe6236f10d0890a0e331e14d901a0ed78f09fe69f53718aec94f9be5afa
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.24.6.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.24.6.ebuild
new file mode 100644
index 000000000000..0c52994f0a29
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.24.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.92.0
+QTMIN=5.15.4
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}