summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-embedded/esptool/Manifest1
-rw-r--r--dev-embedded/esptool/esptool-3.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-embedded/esptool/Manifest b/dev-embedded/esptool/Manifest
index 9aabd42d1b85..40d6d4e344bd 100644
--- a/dev-embedded/esptool/Manifest
+++ b/dev-embedded/esptool/Manifest
@@ -1 +1,2 @@
DIST esptool-2.8.tar.gz 5399875 BLAKE2B c2c27dc44cec1921f2d800347682bb198be76f7a122fd6a0c9964fb189350980557aa85bd6cb8fb2d63c8c7ccdd18e1860b65ca85c8777145ec1da07da886be1 SHA512 14528197e760779f3bf50e2a44d477979675dd42451fa405e2ae87502158b21f999fb94561980c9eb0634d2d1fd3729779b78266403de858ed1d32e8d29604cc
+DIST esptool-3.0.tar.gz 6628258 BLAKE2B 613bdc4c4d0df633c25c83d51a84ff9ca34d5c345f010d2e3e99bc126530d484bb1fb4818b3a10b10a6b9879b161817d5bc6288dab55368f1250a27e2418d641 SHA512 b522d30b11e9ab4e426009116bf1872e587116b7a3b517f841d34d3e860f6454345be89a2e28b8eef5aa5e59318e991504697644a3f4f90d7e63c037025716eb
diff --git a/dev-embedded/esptool/esptool-3.0.ebuild b/dev-embedded/esptool/esptool-3.0.ebuild
new file mode 100644
index 000000000000..d66949a64efa
--- /dev/null
+++ b/dev-embedded/esptool/esptool-3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
+HOMEPAGE="https://github.com/espressif/esptool"
+SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/bitstring[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/ecdsa-0.16.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyserial[${PYTHON_MULTI_USEDEP}]
+ dev-python/reedsolomon[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+BDEPEND="
+ test? ( $(python_gen_cond_dep 'dev-python/pyelftools[${PYTHON_MULTI_USEDEP}]') )
+"
+
+python_test() {
+ ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
+ ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
+ ${EPYTHON} test/test_espefuse_host.py || die "espefuse_host test failed with ${EPYTHON}"
+ # test/test_esptool.py and test/test_espefuse.py need real hardware connected
+}