summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/net-tools/net-tools-9999.ebuild24
1 files changed, 3 insertions, 21 deletions
diff --git a/sys-apps/net-tools/net-tools-9999.ebuild b/sys-apps/net-tools/net-tools-9999.ebuild
index 1fd92a62a67f..5aae5ffbd1cf 100644
--- a/sys-apps/net-tools/net-tools-9999.ebuild
+++ b/sys-apps/net-tools/net-tools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
inherit flag-o-matic toolchain-funcs
@@ -9,7 +9,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://git.code.sf.net/p/net-tools/code"
inherit git-r3
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ SRC_URI="mirror://sourceforge/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
@@ -32,24 +32,6 @@ RDEPEND+="
hostname? ( !sys-apps/coreutils[hostname] )
!<sys-apps/openrc-0.9.9.3"
-maint_pkg_create() {
- cd /usr/local/src/net-tools
- #git-update
- local stamp=$(date --date="$(git log -n1 --pretty=format:%ci master)" -u +%Y%m%d%H%M%S)
- local pv="${PV/_p*}_p${stamp}"; pv=${pv/9999/1.60}
- local p="${PN}-${pv}"
- git archive --prefix="${p}/" master | tar xf - -C "${T}"
- pushd "${T}" >/dev/null
- emake -C "${p}/po" dist
- sed -i "/^RELEASE/s:=.*:=${pv}:" */Makefile || die
- tar --exclude-vcs cf - ${p}/ | xz > ${p}.tar.xz
- popd >/dev/null
-
- du -b "${T}"/*.tar.xz
-}
-
-pkg_setup() { [[ -n ${VAPIER_LOVES_YOU} ]] && maint_pkg_create ; }
-
set_opt() {
local opt=$1 ans
shift