summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/json-schema/Manifest1
-rw-r--r--dev-php/json-schema/json-schema-4.1.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/json-schema/Manifest b/dev-php/json-schema/Manifest
index 6c3b3eea62ef..f29dc119d6f2 100644
--- a/dev-php/json-schema/Manifest
+++ b/dev-php/json-schema/Manifest
@@ -1 +1,2 @@
DIST json-schema-2.0.0.tar.gz 21319 SHA256 bdbaedf8be4bb2ceb8019c651b0579a4b9723dc95e11f0aa683cfe193064e392 SHA512 8efa6ad3175b474e3c073816651d77e80e3ec7865aa6a04f8c7eff7a91831ab1eb1b0b6968d542aa6d10e1e0a1171ec05889b817713f1d740afeb31c5f124a52 WHIRLPOOL 5af244685521d57b663faf78f287a978e7b8bb89526ad8f282fb7d57490540fd483501752bc27b75d6b2de9699d2684352a0e5711fed98b5c6e9cf2f0437b0d9
+DIST json-schema-4.1.0.tar.gz 24772 SHA256 8470ef4f5b55018102911a2403184215e5c3459ceb6bf3ce9bdb8cceed469284 SHA512 5c6bda8c34012bc20d9bf604a6183d50f451327bded70d94415450d2b3cc8e7f6f416ddd8b13db0aeb487fe031fe3185aebd9c97e4c1f79c866dcbc3463f64d0 WHIRLPOOL a6b9db1b0838f7887b3408eba72655d7108ffd9198a7ca15f89538a743b36ac167b4334a9de902eca61d751a060fb373bab1083502c4b198142a54cdd560f269
diff --git a/dev-php/json-schema/json-schema-4.1.0.ebuild b/dev-php/json-schema/json-schema-4.1.0.ebuild
new file mode 100644
index 000000000000..9412e627e0ea
--- /dev/null
+++ b/dev-php/json-schema/json-schema-4.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP implementation of JSON schema"
+HOMEPAGE="https://github.com/justinrainbow/json-schema"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# Tests are not in the release tarball
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/JsonSchema"
+ doins -r src/JsonSchema/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}