summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/zfs-kmod/Manifest2
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-2.2.0.ebuild217
2 files changed, 0 insertions, 219 deletions
diff --git a/sys-fs/zfs-kmod/Manifest b/sys-fs/zfs-kmod/Manifest
index 08acc4fbbfa4..4b19d24cad35 100644
--- a/sys-fs/zfs-kmod/Manifest
+++ b/sys-fs/zfs-kmod/Manifest
@@ -2,7 +2,5 @@ DIST zfs-2.1.12.tar.gz 35155013 BLAKE2B 652780e6bf7b63f45909110726d53795fada034f
DIST zfs-2.1.12.tar.gz.asc 836 BLAKE2B 9215e732981a82254115cd17ec3c9810d4e9e5d5f7bb848778848f911478fc2e4bdbfc563e9835a2e876c26d9e0e8755724a0995baf9ad24e9265123e10cfddf SHA512 69c8b618947fd966eba0bba1c7326ddd463861f051a6cf1d06e23bd6d840fe7503f02adec2c3cbb203fa7b1cced51500f3689c224b653d13d227edd51b5a44f6
DIST zfs-2.1.13.tar.gz 35170063 BLAKE2B 88f4b27a872071590294cf2a93d19633bacfaf1214fc4f06ab7ae7778376978754e0e2566d7bfe659d84426f525ecd05679b98310ddfc2d5938804c36fd03904 SHA512 d06fce8faa22b0cab2c69befa3842476703433fa90530d1fdf168716afd2039e97b124aa8ef581bed3bc19604fa2faa0bc1e29f6d028e3ef0085f0e34e05230a
DIST zfs-2.1.13.tar.gz.asc 836 BLAKE2B 35d3299cfe1d37848f1a0e75a00e08a49a37356ccfc2f47fa1c5c64a1e16adc8030c35047fb45347ec4328d90703ed1623de1c799bef9b6297553aa7b357e8da SHA512 f35c89fd6b1019098b103427b525e32a691c796debde743f9d99953623d8c2bc6deb1ed88865e519d5fa60b259b1d74cce3c829dd1e2eb59aa29abc20046a0db
-DIST zfs-2.2.0.tar.gz 33826037 BLAKE2B 80d94cd5ef0bbeaa570853c10f480e3cd64cb852b53aced2e7d382d097130fcf8f94060126a04321f913bca5d9158813a74e97f1dd0f110359d911a33e4a0d77 SHA512 6a45419d2cd30a4f65c50410568972ba9a27f87e745d7a46c0757d7deb4377150f9bd752d54b4bda26badfc40922c34dc5d5bf50f76c84398811784243606829
-DIST zfs-2.2.0.tar.gz.asc 195 BLAKE2B c3e665380060b605c5f8ce120f8cc00457053b8adaf44307500a47ff5cd00be04306920820c7a8c1832eb770d5189fd747a52cf13d8bdd8fccbcb171b9b4afad SHA512 b52a11d3e27adf606c24fab46307153c9f81cd8ac504aa8995f7add3e25cd3c00fcb8e2faae3c1a70e29f5901117f961ded7fc26ae5701098a6bcf9710d216f7
DIST zfs-2.2.1.tar.gz 33814243 BLAKE2B c3ff95c892024a11ee5c266b10e3354074606665a201fbab16e1ed12550340e0d991d98bd74f794331b68bd16cd6147a9e8937b8cda72d454abce72a22bafec6 SHA512 05e17046ac4f0ba923151be3e554e075db4783c8936c5dcee2d3b6d459fb386ba33f9eb38d15c185db58a1d26926147a66c3b3fe14e9de40987f0e95efa2bb31
DIST zfs-2.2.1.tar.gz.asc 836 BLAKE2B 9d586d703d557df020f1d02e764f488f354f5c7105e7fa0f3dbf040881b63bdffa3310c9048ed102be05e9c851242b572cd0c6a22361e7e5a1cce50b1644a98d SHA512 78a13f42a71e39d346d43f3e1b271483b4b426ccdcda7f3709db8d89b0bcd54c79b7d17cfe3b49d2e6b8c7c41e30e69faade02e49e4bdddb3e472f2ceeb29cf2
diff --git a/sys-fs/zfs-kmod/zfs-kmod-2.2.0.ebuild b/sys-fs/zfs-kmod/zfs-kmod-2.2.0.ebuild
deleted file mode 100644
index e3f1e276b22c..000000000000
--- a/sys-fs/zfs-kmod/zfs-kmod-2.2.0.ebuild
+++ /dev/null
@@ -1,217 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools dist-kernel-utils flag-o-matic linux-mod-r1 multiprocessing
-
-DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
-HOMEPAGE="https://github.com/openzfs/zfs"
-
-MODULES_KERNEL_MAX=6.5
-MODULES_KERNEL_MIN=3.10
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/openzfs/zfs.git"
- inherit git-r3
- unset MODULES_KERNEL_MAX
-else
- VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/openzfs.asc
- inherit verify-sig
-
- MY_PV=${PV/_rc/-rc}
- SRC_URI="https://github.com/openzfs/zfs/releases/download/zfs-${MY_PV}/zfs-${MY_PV}.tar.gz"
- SRC_URI+=" verify-sig? ( https://github.com/openzfs/zfs/releases/download/zfs-${MY_PV}/zfs-${MY_PV}.tar.gz.asc )"
- S="${WORKDIR}/zfs-${MY_PV}"
-
- ZFS_KERNEL_COMPAT="${MODULES_KERNEL_MAX}"
- # Increments minor eg 5.14 -> 5.15, and still supports override.
- ZFS_KERNEL_DEP="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
- ZFS_KERNEL_DEP="${ZFS_KERNEL_DEP%%.*}.$(( ${ZFS_KERNEL_DEP##*.} + 1))"
-
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~sparc"
- fi
-fi
-
-LICENSE="CDDL MIT debug? ( GPL-2+ )"
-SLOT="0/${PVR}"
-IUSE="custom-cflags debug +rootfs"
-RESTRICT="test"
-
-BDEPEND="
- app-alternatives/awk
- dev-lang/perl
-"
-
-if [[ ${PV} != 9999 ]] ; then
- BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-openzfs )"
-
- IUSE+=" +dist-kernel-cap"
- RDEPEND="
- dist-kernel-cap? ( dist-kernel? (
- <virtual/dist-kernel-${ZFS_KERNEL_DEP}
- ) )
- "
-fi
-
-# Used to suggest matching USE, but without suggesting to disable
-PDEPEND="dist-kernel? ( ~sys-fs/zfs-${PV}[dist-kernel] )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.11-gentoo.patch
-)
-
-pkg_pretend() {
- use rootfs || return 0
-
- if has_version virtual/dist-kernel && ! use dist-kernel; then
- ewarn "You have virtual/dist-kernel installed, but"
- ewarn "USE=\"dist-kernel\" is not enabled for ${CATEGORY}/${PN}"
- ewarn "It's recommended to globally enable dist-kernel USE flag"
- ewarn "to auto-trigger initrd rebuilds with kernel updates"
- fi
-}
-
-pkg_setup() {
- local CONFIG_CHECK="
- EFI_PARTITION
- ZLIB_DEFLATE
- ZLIB_INFLATE
- !DEBUG_LOCK_ALLOC
- !PAX_KERNEXEC_PLUGIN_METHOD_OR
- "
- use debug && CONFIG_CHECK+="
- DEBUG_INFO
- FRAME_POINTER
- !DEBUG_INFO_REDUCED
- "
- use rootfs && CONFIG_CHECK+="
- BLK_DEV_INITRD
- DEVTMPFS
- "
-
- kernel_is -lt 5 && CONFIG_CHECK+=" IOSCHED_NOOP"
-
- if [[ ${PV} != 9999 ]] ; then
- local kv_major_max kv_minor_max zcompat
- zcompat="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
- kv_major_max="${zcompat%%.*}"
- zcompat="${zcompat#*.}"
- kv_minor_max="${zcompat%%.*}"
- kernel_is -le "${kv_major_max}" "${kv_minor_max}" || die \
- "Linux ${kv_major_max}.${kv_minor_max} is the latest supported version"
- fi
-
- linux-mod-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Run unconditionally (bug #792627)
- eautoreconf
-
- if [[ ${PV} != 9999 ]] ; then
- # Set module revision number
- sed -Ei "s/(Release:.*)1/\1${PR}-gentoo/" META || die
- fi
-}
-
-src_configure() {
- use custom-cflags || strip-flags
- filter-ldflags -Wl,*
-
- local myconf=(
- --bindir="${EPREFIX}"/bin
- --sbindir="${EPREFIX}"/sbin
- --with-config=kernel
- --with-linux="${KV_DIR}"
- --with-linux-obj="${KV_OUT_DIR}"
- $(use_enable debug)
-
- # See gentoo.patch
- GENTOO_MAKEARGS_EVAL="${MODULES_MAKEARGS[*]@Q}"
- TEST_JOBS="$(makeopts_jobs)"
- )
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake "${MODULES_MAKEARGS[@]}"
-}
-
-src_install() {
- emake "${MODULES_MAKEARGS[@]}" DESTDIR="${ED}" install
- modules_post_process
-
- dodoc AUTHORS COPYRIGHT META README.md
-}
-
-_old_layout_cleanup() {
- # new files are just extra/{spl,zfs}.ko with no subdirs.
- local olddir=(
- avl/zavl
- icp/icp
- lua/zlua
- nvpair/znvpair
- spl/spl
- unicode/zunicode
- zcommon/zcommon
- zfs/zfs
- zstd/zzstd
- )
-
- # kernel/module/Kconfig contains possible compressed extentions.
- local kext kextfiles
- for kext in .ko{,.{gz,xz,zst}}; do
- kextfiles+=( "${olddir[@]/%/${kext}}" )
- done
-
- local oldfile oldpath
- for oldfile in "${kextfiles[@]}"; do
- oldpath="${EROOT}/lib/modules/${KV_FULL}/extra/${oldfile}"
- if [[ -f "${oldpath}" ]]; then
- ewarn "Found obsolete zfs module ${oldfile} for current kernel ${KV_FULL}, removing."
- rm -rv "${oldpath}" || die
- # we do not remove non-empty directories just for safety in case there's something else.
- # also it may fail if there are both compressed and uncompressed modules installed.
- rmdir -v --ignore-fail-on-non-empty "${oldpath%/*.*}" || die
- fi
- done
-}
-
-pkg_postinst() {
- # Check for old module layout before doing anything else.
- # only attempt layout cleanup if new .ko location is used.
- local newko=( "${EROOT}/lib/modules/${KV_FULL}/extra"/{zfs,spl}.ko* )
- # We check first array member, if glob above did not exand, it will be "zfs.ko*" and -f will return false.
- # if glob expanded -f will do correct file precense check.
- [[ -f ${newko[0]} ]] && _old_layout_cleanup
-
- linux-mod-r1_pkg_postinst
-
- if [[ -z ${ROOT} ]] && use dist-kernel ; then
- dist-kernel_reinstall_initramfs "${KV_DIR}" "${KV_FULL}"
- fi
-
- if use x86 || use arm ; then
- ewarn "32-bit kernels will likely require increasing vmalloc to"
- ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
- fi
-
- if has_version sys-boot/grub ; then
- ewarn "This version of OpenZFS includes support for new feature flags"
- ewarn "that are incompatible with previous versions. GRUB2 support for"
- ewarn "/boot with the new feature flags is not yet available."
- ewarn "Do *NOT* upgrade root pools to use the new feature flags."
- ewarn "Any new pools will be created with the new feature flags by default"
- ewarn "and will not be compatible with older versions of OpenZFS. To"
- ewarn "create a new pool that is backward compatible wih GRUB2, use "
- ewarn
- ewarn "zpool create -o compatibility=grub2 ..."
- ewarn
- ewarn "Refer to /usr/share/zfs/compatibility.d/grub2 for list of features."
- fi
-}