summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmxres/files/wmxres-1.2-gcc-10.patch21
-rw-r--r--x11-plugins/wmxres/wmxres-1.2-r1.ebuild3
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-plugins/wmxres/files/wmxres-1.2-gcc-10.patch b/x11-plugins/wmxres/files/wmxres-1.2-gcc-10.patch
new file mode 100644
index 000000000000..5beb41552562
--- /dev/null
+++ b/x11-plugins/wmxres/files/wmxres-1.2-gcc-10.patch
@@ -0,0 +1,21 @@
+--- a/wmgeneral/wmgeneral.c
++++ b/wmgeneral/wmgeneral.c
+@@ -45,6 +45,7 @@ Window iconwin, win;
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ /*****************/
+ /* Mouse Regions */
+--- a/wmgeneral/wmgeneral.h
++++ b/wmgeneral/wmgeneral.h
+@@ -21,7 +21,7 @@ typedef struct {
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmxres/wmxres-1.2-r1.ebuild b/x11-plugins/wmxres/wmxres-1.2-r1.ebuild
index 993a4f040d46..763a7d022d4a 100644
--- a/x11-plugins/wmxres/wmxres-1.2-r1.ebuild
+++ b/x11-plugins/wmxres/wmxres-1.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,7 @@ S="${WORKDIR}/${PN}.app"
PATCHES=(
"${FILESDIR}"/${PN}-debian-1.1-1.2.patch
"${FILESDIR}"/${PN}-1.2-r1-fix-build-system.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
)
src_configure() {