summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/grfcodec/files/grfcodec-6.0.6-gcc10.patch12
-rw-r--r--games-util/grfcodec/grfcodec-6.0.6.ebuild4
2 files changed, 15 insertions, 1 deletions
diff --git a/games-util/grfcodec/files/grfcodec-6.0.6-gcc10.patch b/games-util/grfcodec/files/grfcodec-6.0.6-gcc10.patch
new file mode 100644
index 000000000000..baf84a435f69
--- /dev/null
+++ b/games-util/grfcodec/files/grfcodec-6.0.6-gcc10.patch
@@ -0,0 +1,12 @@
+diff -Nrup a/src/command.cpp b/src/command.cpp
+--- a/src/command.cpp 2015-05-09 04:59:46.000000000 -0600
++++ b/src/command.cpp 2019-09-24 11:37:06.667911307 -0600
+@@ -303,7 +303,7 @@ bool parse_comment(const string&line){
+ uint val=find_command(command_part,beaut),togglebit;
+ if(val!=(uint)-1&&val!=OFF)_commandState.beautifier=true;
+ switch(val){
+- case -1:
++ case -1u:
+ IssueMessage(0,COMMAND_INVALID_ARG,gen[BEAUTIFY].name);
+ return true;
+ case OFF:_commandState.beautifier=false;break;
diff --git a/games-util/grfcodec/grfcodec-6.0.6.ebuild b/games-util/grfcodec/grfcodec-6.0.6.ebuild
index ebfb9b894f6b..2c4927b37555 100644
--- a/games-util/grfcodec/grfcodec-6.0.6.ebuild
+++ b/games-util/grfcodec/grfcodec-6.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,6 +27,8 @@ DEPEND="
dev-libs/boost
"
+PATCHES=("${FILESDIR}/${PN}-6.0.6-gcc10.patch")
+
src_prepare() {
default