summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/ondir/Manifest1
-rw-r--r--app-misc/ondir/ondir-0.2.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/ondir/Manifest b/app-misc/ondir/Manifest
index 2ad9659cf956..0cc2e1a4bc80 100644
--- a/app-misc/ondir/Manifest
+++ b/app-misc/ondir/Manifest
@@ -1 +1,2 @@
DIST ondir-0.2.2.tar.gz 20138 BLAKE2B 3724b8d356cec16e1f60ec49574e2f688d4f7456f48f1d909402e8436f588d9617c827eda9a74c1b930d2538fe8c9d1372a1d222124d8f7b863bf8e895cfaa25 SHA512 5c2c53532934b25d2a170c619d067c369b6acf2ef3e0a87607619613dcc0bbfc570937fb91cdc5df3f22ae0453b5a5d00edd57cd1b852f7a076c15b96c45d4dd
+DIST ondir-0.2.4.tar.gz 52860 BLAKE2B e9111f9a64d8d7393d9a8e48d5dc66d5814995ae1dbd2f577538a03021c1b1b92af43acbd0ab9cb24ab29ba16c50d5752a9442689effc62bd8c13b6fe11a4785 SHA512 f59a823807f86ce2992aaf5fb174ddea222b02ed18e1289ca450179bd090892f1467072dfcec97ce219e216c055781ea7a1a05bb9402276fb9404a57f42ddb52
diff --git a/app-misc/ondir/ondir-0.2.4.ebuild b/app-misc/ondir/ondir-0.2.4.ebuild
new file mode 100644
index 000000000000..2f51ec18dee6
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automatically execute scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL scripts.tcsh scripts.sh )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\(/man/.*$\):/share\1:g" \
+ -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ install
+ newdoc ondirrc.eg ondirrc.example
+}