summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/pkgdev/Manifest1
-rw-r--r--dev-util/pkgdev/pkgdev-0.2.4.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-util/pkgdev/Manifest b/dev-util/pkgdev/Manifest
index 69ae4adf1d24..456cea14ffae 100644
--- a/dev-util/pkgdev/Manifest
+++ b/dev-util/pkgdev/Manifest
@@ -1,2 +1 @@
-DIST pkgdev-0.2.4.tar.gz 64156 BLAKE2B 321e14b246a97236142a862968bfc127f3215314ef173dc0d610ca867d00a0db067def7810083b11bf6aea1e36202e6c91d7c63d74aa2b85fb17ec476cba1f7c SHA512 0390e130abda2f8eea1d3dd029d31d9381f2543ca98f547b91716ce383791c3760bd89bb276b5b15eaaa165be339c8147d26e93ba81d5be4c8a4cbede6a31caf
DIST pkgdev-0.2.5.tar.gz 76886 BLAKE2B c1f5789ab7d9ef425d5fe444e046e0f9df8c5725e663177f997e9e8849b95af9a3ad022bf474791eba37b74e369028471187cf2b2d62aea0a1246e8d6cfa4a39 SHA512 29a271b92e9272428f28b7a4530fe8cb1e392b5c9ef46dbd98ac130e4ec01eb8f584ca297a7dd3bc4dded9713823dafd8dc0b722d066d6360befd6637388284f
diff --git a/dev-util/pkgdev/pkgdev-0.2.4.ebuild b/dev-util/pkgdev/pkgdev-0.2.4.ebuild
deleted file mode 100644
index 4b29fa2379bd..000000000000
--- a/dev-util/pkgdev/pkgdev-0.2.4.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 optfeature
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgdev.git
- https://github.com/pkgcore/pkgdev.git"
- inherit git-r3
-else
- inherit pypi
- KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
-fi
-
-DESCRIPTION="Collection of tools for Gentoo development"
-HOMEPAGE="https://github.com/pkgcore/pkgdev"
-
-LICENSE="BSD MIT"
-SLOT="0"
-
-if [[ ${PV} == *9999 ]] ; then
- RDEPEND="
- ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- ~dev-util/pkgcheck-9999[${PYTHON_USEDEP}]
- ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
- "
-else
- RDEPEND="
- >=dev-python/snakeoil-0.10.3[${PYTHON_USEDEP}]
- >=dev-util/pkgcheck-0.10.16[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.12.16[${PYTHON_USEDEP}]
- "
-fi
-
-RDEPEND+="
- dev-vcs/git
-"
-BDEPEND="
- >=dev-python/flit_core-3.8[${PYTHON_USEDEP}]
- test? (
- x11-misc/xdg-utils
- )
-"
-
-distutils_enable_sphinx doc \
- ">=dev-python/snakeoil-0.10.3" \
- dev-python/tomli
-distutils_enable_tests pytest
-
-python_compile_all() {
- use doc && emake PYTHON="${EPYTHON}" man
-
- sphinx_compile_all # HTML pages only
-}
-
-python_install_all() {
- # If USE=doc, there'll be newly generated docs which we install instead.
- if use doc || [[ ${PV} != *9999 ]]; then
- doman build/sphinx/man/*
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "sending email support" x11-misc/xdg-utils
-}