summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/libreoffice/libreoffice-5.1.1.3.ebuild7
-rw-r--r--app-office/libreoffice/libreoffice-5.1.9999.ebuild7
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/app-office/libreoffice/libreoffice-5.1.1.3.ebuild b/app-office/libreoffice/libreoffice-5.1.1.3.ebuild
index 56ec41944e48..5abaa476e404 100644
--- a/app-office/libreoffice/libreoffice-5.1.1.3.ebuild
+++ b/app-office/libreoffice/libreoffice-5.1.1.3.ebuild
@@ -266,7 +266,12 @@ PATCHES=(
)
CHECKREQS_MEMORY="512M"
-if [[ ${MERGE_TYPE} != binary ]] ; then CHECKREQS_DISK_BUILD="6G" ; fi
+
+if [[ ${MERGE_TYPE} != binary ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ CHECKREQS_DISK_BUILD="22G"
+elif [[ ${MERGE_TYPE} != binary ]] ; then
+ CHECKREQS_DISK_BUILD="6G"
+fi
pkg_pretend() {
local pgslot
diff --git a/app-office/libreoffice/libreoffice-5.1.9999.ebuild b/app-office/libreoffice/libreoffice-5.1.9999.ebuild
index 11c9a864a2bf..940c4be4d24d 100644
--- a/app-office/libreoffice/libreoffice-5.1.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-5.1.9999.ebuild
@@ -263,7 +263,12 @@ PATCHES=(
)
CHECKREQS_MEMORY="512M"
-if [[ ${MERGE_TYPE} != binary ]] ; then CHECKREQS_DISK_BUILD="6G" ; fi
+
+if [[ ${MERGE_TYPE} != binary ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ CHECKREQS_DISK_BUILD="22G"
+elif [[ ${MERGE_TYPE} != binary ]] ; then
+ CHECKREQS_DISK_BUILD="6G"
+fi
pkg_pretend() {
local pgslot
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 4686600c380e..f61e42c48029 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -258,7 +258,12 @@ PATCHES=(
)
CHECKREQS_MEMORY="512M"
-if [[ ${MERGE_TYPE} != binary ]] ; then CHECKREQS_DISK_BUILD="6G" ; fi
+
+if [[ ${MERGE_TYPE} != binary ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ CHECKREQS_DISK_BUILD="22G"
+elif [[ ${MERGE_TYPE} != binary ]] ; then
+ CHECKREQS_DISK_BUILD="6G"
+fi
pkg_pretend() {
local pgslot