summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/wireshark/metadata.xml2
-rw-r--r--net-analyzer/wireshark/wireshark-3.0.0_rc2.ebuild21
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild23
-rw-r--r--profiles/features/selinux/package.use.mask4
4 files changed, 39 insertions, 11 deletions
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index d78579251147..3aea5c6b5d54 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -35,6 +35,7 @@ be exported to XML, PostScript®, CSV, or plain text.
<flag name="ciscodump">Install ciscodump, extcap interface to capture from a remote Cisco router</flag>
<flag name="dftest">Install dftest, to display filter byte-code, for debugging dfilter routines</flag>
<flag name="doc-pdf">Build documentation in pdf format (US and a4 paper sizes)</flag>
+<flag name="dpauxmon">Install dpauxmon, an external capture interface (extcap) that captures DisplayPort AUX channel data from linux kernel drivers</flag>
<flag name="dumpcap">Install dumpcap, to dump network traffic from inside wireshark</flag>
<flag name="editcap">Install editcap, to edit and/or translate the format of capture files</flag>
<flag name="libssh">Use <pkg>net-libs/libssh</pkg> (for sshdump)</flag>
@@ -49,6 +50,7 @@ be exported to XML, PostScript®, CSV, or plain text.
<flag name="randpktdump">Install randpktdump, an extcap interface to provide access to the random packet generator (randpkt)</flag>
<flag name="reordercap">Install reordercap, to reorder input file by timestamp into output file</flag>
<flag name="sbc">Use <pkg>media-libs/sbc</pkg> for playing back SBC encoded packets</flag>
+<flag name="sdjournal">Install sdjournal, an extcap that captures systemd journal entries</flag>
<flag name="sharkd">Install sharkd, the daemon variant of wireshark</flag>
<flag name="smi">Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
<flag name="snappy">Use <pkg>app-arch/snappy</pkg> for snappy compression and decompression</flag>
diff --git a/net-analyzer/wireshark/wireshark-3.0.0_rc2.ebuild b/net-analyzer/wireshark/wireshark-3.0.0_rc2.ebuild
index e7f6b3df2dba..7824e565a937 100644
--- a/net-analyzer/wireshark/wireshark-3.0.0_rc2.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.0.0_rc2.ebuild
@@ -13,10 +13,11 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~x86"
IUSE="
- adns androiddump bcg729 +capinfos +captype ciscodump +dftest doc +dumpcap
- +editcap kerberos libxml2 lua lz4 maxminddb +mergecap +netlink nghttp2
- +pcap +qt5 +randpkt +randpktdump +reordercap sbc selinux +sharkd smi snappy
- spandsp sshdump ssl +text2pcap tfshark +tshark +udpdump zlib
+ adns androiddump bcg729 +capinfos +captype ciscodump +dftest doc dpauxmon
+ +dumpcap +editcap kerberos libxml2 lua lz4 maxminddb +mergecap +netlink
+ nghttp2 +pcap +qt5 +randpkt +randpktdump +reordercap sbc selinux +sharkd
+ smi snappy spandsp sshdump ssl sdjournal +text2pcap tfshark +tshark
+ +udpdump zlib
"
S=${WORKDIR}/${P/_/}
@@ -45,6 +46,7 @@ CDEPEND="
x11-misc/xdg-utils
)
sbc? ( media-libs/sbc )
+ sdjournal? ( sys-apps/systemd )
smi? ( net-libs/libsmi )
snappy? ( app-arch/snappy )
spandsp? ( media-libs/spandsp )
@@ -76,7 +78,9 @@ RDEPEND="
qt5? ( virtual/freedesktop-icon-theme )
selinux? ( sec-policy/selinux-wireshark )
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
PATCHES=(
"${FILESDIR}"/${PN}-2.4-androiddump.patch
"${FILESDIR}"/${PN}-2.6.0-redhat.patch
@@ -124,6 +128,7 @@ src_configure() {
-DBUILD_captype=$(usex captype)
-DBUILD_ciscodump=$(usex ciscodump)
-DBUILD_dftest=$(usex dftest)
+ -DBUILD_dpauxmon=$(usex dpauxmon)
-DBUILD_dumpcap=$(usex dumpcap)
-DBUILD_editcap=$(usex editcap)
-DBUILD_mergecap=$(usex mergecap)
@@ -131,6 +136,7 @@ src_configure() {
-DBUILD_randpkt=$(usex randpkt)
-DBUILD_randpktdump=$(usex randpktdump)
-DBUILD_reordercap=$(usex reordercap)
+ -DBUILD_sdjournal=$(usex sdjournal)
-DBUILD_sharkd=$(usex sharkd)
-DBUILD_sshdump=$(usex sshdump)
-DBUILD_text2pcap=$(usex text2pcap)
@@ -160,6 +166,11 @@ src_configure() {
cmake-utils_src_configure
}
+src_test() {
+ emake -C "${BUILD_DIR}" test-programs
+ emake -C "${BUILD_DIR}" test
+}
+
src_install() {
cmake-utils_src_install
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 1971febe690d..e9927cc3b151 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,10 +13,11 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="
- adns androiddump bcg729 +capinfos +captype ciscodump +dftest doc +dumpcap
- +editcap kerberos libxml2 lua lz4 maxminddb +mergecap +netlink nghttp2
- +pcap +qt5 +randpkt +randpktdump +reordercap sbc selinux +sharkd smi snappy
- spandsp sshdump ssl +text2pcap tfshark +tshark +udpdump zlib
+ adns androiddump bcg729 +capinfos +captype ciscodump +dftest doc dpauxmon
+ +dumpcap +editcap kerberos libxml2 lua lz4 maxminddb +mergecap +netlink
+ nghttp2 +pcap +qt5 +randpkt +randpktdump +reordercap sbc selinux +sharkd
+ smi snappy spandsp sshdump ssl sdjournal +text2pcap tfshark +tshark
+ +udpdump zlib
"
S=${WORKDIR}/${P/_/}
@@ -45,6 +46,7 @@ CDEPEND="
x11-misc/xdg-utils
)
sbc? ( media-libs/sbc )
+ sdjournal? ( sys-apps/systemd )
smi? ( net-libs/libsmi )
snappy? ( app-arch/snappy )
spandsp? ( media-libs/spandsp )
@@ -76,7 +78,9 @@ RDEPEND="
qt5? ( virtual/freedesktop-icon-theme )
selinux? ( sec-policy/selinux-wireshark )
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
PATCHES=(
"${FILESDIR}"/${PN}-2.4-androiddump.patch
"${FILESDIR}"/${PN}-2.6.0-redhat.patch
@@ -124,6 +128,7 @@ src_configure() {
-DBUILD_captype=$(usex captype)
-DBUILD_ciscodump=$(usex ciscodump)
-DBUILD_dftest=$(usex dftest)
+ -DBUILD_dpauxmon=$(usex dpauxmon)
-DBUILD_dumpcap=$(usex dumpcap)
-DBUILD_editcap=$(usex editcap)
-DBUILD_mergecap=$(usex mergecap)
@@ -131,6 +136,7 @@ src_configure() {
-DBUILD_randpkt=$(usex randpkt)
-DBUILD_randpktdump=$(usex randpktdump)
-DBUILD_reordercap=$(usex reordercap)
+ -DBUILD_sdjournal=$(usex sdjournal)
-DBUILD_sharkd=$(usex sharkd)
-DBUILD_sshdump=$(usex sshdump)
-DBUILD_text2pcap=$(usex text2pcap)
@@ -160,6 +166,11 @@ src_configure() {
cmake-utils_src_configure
}
+src_test() {
+ emake -C "${BUILD_DIR}" test-programs
+ emake -C "${BUILD_DIR}" test
+}
+
src_install() {
cmake-utils_src_install
diff --git a/profiles/features/selinux/package.use.mask b/profiles/features/selinux/package.use.mask
index d1411f9dbb9e..c143824e7072 100644
--- a/profiles/features/selinux/package.use.mask
+++ b/profiles/features/selinux/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# Jeroen Roovers <jer@gentoo.org> (23 Feb 2019)
+# sdjournal links against sys-apps/systemd's libraries
+net-analyzer/wireshark sdjournal
+
# Brian Dolbec <dolsen@gentoo.org> (17 Sep 2014)
# mask pypy for several utilities due to incompatibility with libselinux
sys-apps/portage python_targets_pypy python_targets_pypy3