summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-rpg/openglad/Manifest1
-rw-r--r--games-rpg/openglad/files/0.98-gladpack.c.patch13
-rw-r--r--games-rpg/openglad/files/openglad-0.98-gcc43.patch11
-rw-r--r--games-rpg/openglad/files/openglad-0.98-ovfl.patch11
-rw-r--r--games-rpg/openglad/openglad-0.98-r1.ebuild42
5 files changed, 0 insertions, 78 deletions
diff --git a/games-rpg/openglad/Manifest b/games-rpg/openglad/Manifest
index 031d8ed8b48f..94107a191738 100644
--- a/games-rpg/openglad/Manifest
+++ b/games-rpg/openglad/Manifest
@@ -1,3 +1,2 @@
-DIST openglad-0.98.tar.gz 724106 BLAKE2B 6cd9df5fd260af9902997bc0708c8285e48081e52fff7af05f432ae94f2f6fdbfba162c664ac4f531796a0372f1be3be064843dad75163e68b7e324b9b6d506d SHA512 3f9165fbf8fff081a862bfe81401a3b2ac227da58b84409beee8b0441f88b1a6deb3d24a1af6e71bd3a3484fc90de5574950fd54be82d837021a07f06302f0e1
DIST openglad-0.98_p20200907.tar.gz 2060013 BLAKE2B 5ea16c0ab13e45f1723ceb0b4167fcbf5863d040e1fc54cd27fa59df14200f84e0e22c0cba87f9ad3294a90850d5b36199cba8e78804d1994fb2dea6ea493fff SHA512 b3bf582a780d90408fc585b28418f462602ec35434c018d6315fb8b119b34cb0dceabcd6b5a6450ba6beb2ab5dc931d6e21ecf46e76853c7f5051c9b3be9014c
DIST openglad.png 5593 BLAKE2B 1fbc5a32861dc4cc5bb4aae4b1b42e92411756618ccfa4172e1494c4f98eb527f6bd36273a250cd7ce721baa76ba80548d75ec1e89b3da134c78d0a7b415b6bd SHA512 27419fcbbbf8640718968304a4824101860736c2091f494defcd111b5cc252856b5373c0e7a2bca1c79f9c7551012b0ba04577f9ed97769e436637ee25f5caeb
diff --git a/games-rpg/openglad/files/0.98-gladpack.c.patch b/games-rpg/openglad/files/0.98-gladpack.c.patch
deleted file mode 100644
index b4f5de9e3995..000000000000
--- a/games-rpg/openglad/files/0.98-gladpack.c.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- openglad-0.98/util/gladpack.c 2002-09-14 18:37:50.000000000 +1000
-+++ openglad-0.98/util/gladpack.c 2003-12-06 12:42:31.393812945 +1100
-@@ -9,8 +9,8 @@
-
- int main(int argc, char **argv)
- {
-- if (argc > 1 && !strcmp(argv[1], "p")) pack(argc, argv);
-- else if (argc > 1 && !strcmp(argv[1], "u")) unpack(argc, argv);
-+ if (argc > 1 && !strcmp(argv[1], "p")) return pack(argc, argv);
-+ else if (argc > 1 && !strcmp(argv[1], "u")) return unpack(argc, argv);
- else
- {
- printf("Usage: gladpack (p|u) ...\n");
diff --git a/games-rpg/openglad/files/openglad-0.98-gcc43.patch b/games-rpg/openglad/files/openglad-0.98-gcc43.patch
deleted file mode 100644
index 9f46ce8e5b95..000000000000
--- a/games-rpg/openglad/files/openglad-0.98-gcc43.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/parser.cpp
-+++ b/src/parser.cpp
-@@ -23,6 +23,8 @@
- #include <iostream>
- #include <fstream>
- #include <string>
-+#include <cstring>
-+#include <cstdlib>
- #include "parser.h"
-
- using namespace std;
diff --git a/games-rpg/openglad/files/openglad-0.98-ovfl.patch b/games-rpg/openglad/files/openglad-0.98-ovfl.patch
deleted file mode 100644
index 8ec89d22559d..000000000000
--- a/games-rpg/openglad/files/openglad-0.98-ovfl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/screen.cpp 2011-07-23 21:35:34.385063301 +0200
-+++ b/src/screen.cpp 2011-07-23 21:35:59.948063312 +0200
-@@ -2383,7 +2383,7 @@
- short listsize;
- short i;
- walker * new_guy;
-- char newgrid[12] = "grid.pix"; // default grid
-+ char newgrid[13] = "grid.pix"; // default grid
- char new_scen_type; // read the scenario type
- char oneline[80];
- char numlines, tempwidth;
diff --git a/games-rpg/openglad/openglad-0.98-r1.ebuild b/games-rpg/openglad/openglad-0.98-r1.ebuild
deleted file mode 100644
index 8d38d5ca0ff0..000000000000
--- a/games-rpg/openglad/openglad-0.98-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils
-
-DESCRIPTION="An SDL clone of Gladiator, a classic RPG game"
-HOMEPAGE="http://snowstorm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/snowstorm/${P}.tar.gz
- mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- media-libs/libsdl[joystick,sound,video]
- media-libs/sdl-image
- media-libs/sdl-mixer"
-RDEPEND=${DEPEND}
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc43.patch
- "${FILESDIR}"/${PV}-gladpack.c.patch
- "${FILESDIR}"/${P}-ovfl.patch
-)
-
-src_configure() {
- econf \
- --prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share/${PN}
-}
-
-src_install() {
- emake install \
- DESTDIR="${D}" \
- docdir="${D}"/usr/share/doc/${PF}
- doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry openglad OpenGladiator
-}