summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/zmap/zmap-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/net-analyzer/zmap/zmap-9999.ebuild b/net-analyzer/zmap/zmap-9999.ebuild
index 04e4602032d2..4d5b862277d5 100644
--- a/net-analyzer/zmap/zmap-9999.ebuild
+++ b/net-analyzer/zmap/zmap-9999.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils fcaps git-r3
+inherit cmake fcaps git-r3
DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
HOMEPAGE="https://zmap.io/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+EGIT_REPO_URI="https://github.com/zmap/zmap.git"
-SLOT="0"
LICENSE="Apache-2.0"
-KEYWORDS=""
+SLOT="0"
IUSE="redis"
RDEPEND="
@@ -32,7 +30,7 @@ src_configure() {
-DWITH_WERROR=OFF
-DWITH_REDIS="$(usex redis)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
FILECAPS=( cap_net_raw=ep usr/sbin/zmap )