summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/cddlib/Manifest1
-rw-r--r--sci-libs/cddlib/cddlib-094j.ebuild53
-rw-r--r--sci-libs/cddlib/metadata.xml35
3 files changed, 81 insertions, 8 deletions
diff --git a/sci-libs/cddlib/Manifest b/sci-libs/cddlib/Manifest
index 7a0484d9543b..4016b91729db 100644
--- a/sci-libs/cddlib/Manifest
+++ b/sci-libs/cddlib/Manifest
@@ -1,2 +1,3 @@
+DIST cddlib-0.94j.tar.gz 1364746 BLAKE2B 60e81fccf8abd8d60fb7261d1d2d61b7ad2b60285e7dfa760905e2cb5b01f1570c27920728c12fc6994135e4b29ba8e1709066ddf2e2eff00f8f48b093ebd43e SHA512 b82d5e06538a29143a79f7ba7287a1784292e28f086071041e500fd81387a30c3fca6fae9049752f57b62d50b385d73681276d42d24941e3a43893da00452ea6
DIST cddlib-094g.tar.gz 1383388 BLAKE2B c26f201f0369a931d672b192d6fab775210d2758e980cf867cf64f34d2ff3b23d862942507ae497c37723cdfe0c7beb55fe5d6cbe02349f576349579adbd4166 SHA512 e1053c6e34f79add53b2880c7664f9c20c0a6de636aa5de4c6a9dfc4d1d241221601c37d15e1833bcd5b1162512c3fbaed4046f771bc0a1e5753b713d6840b77
DIST cddlib-094h.tar.gz 1678116 BLAKE2B 619e26745c04338d97fb4ce2997c23a16017ed19e14dda24c9ef90b84253d5540361b4ccd68eafb65b6380cff95b58e9ec2bf587643e71084cd47ed87bdffbc9 SHA512 22160c88832b78dd568b58c1e097e4c6006f82580f1114a3ef03fc10bde98132337d5b555306b58b65aac6fea1534d9e09725907808c969de16c2dfc75f80204
diff --git a/sci-libs/cddlib/cddlib-094j.ebuild b/sci-libs/cddlib/cddlib-094j.ebuild
new file mode 100644
index 000000000000..73468ab72e6d
--- /dev/null
+++ b/sci-libs/cddlib/cddlib-094j.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This should have been dealt with versionator in the direction
+# 0.94x -> 094x - now we are screwed.
+MY_PV="0.94j"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="C library implementing the Double Description Method"
+HOMEPAGE="https://www.inf.ethz.ch/personal/fukudak/cdd_home/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs tools"
+
+DEPEND="dev-libs/gmp:0"
+RDEPEND="dev-libs/gmp:0="
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use tools; then
+ rm "${ED}"/usr/bin/* || die
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ # Nobody wants the dvi/ps manual...
+ rm "${ED}/usr/share/doc/${PF}"/cddlibman.{dvi,ps} || die
+
+ # since the PDF manual is installed by default.
+ if ! use doc; then
+ rm "${ED}/usr/share/doc/${PF}"/cddlibman.pdf || die
+ fi
+
+ # The docs and examples are *both* installed by default, so we
+ # have to remove the examples if the user doesn't want them.
+ docompress -x "/usr/share/doc/${PF}"/examples{,-ext,-ine,-ine3d}
+ if ! use examples; then
+ rm -r "${ED}/usr/share/doc/${PF}"/examples{,-ext,-ine,-ine3d} || die
+ fi
+}
diff --git a/sci-libs/cddlib/metadata.xml b/sci-libs/cddlib/metadata.xml
index a93a12f9174f..eebce0ab1969 100644
--- a/sci-libs/cddlib/metadata.xml
+++ b/sci-libs/cddlib/metadata.xml
@@ -1,29 +1,48 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<maintainer type="project">
<email>sci-mathematics@gentoo.org</email>
<name>Gentoo Mathematics Project</name>
</maintainer>
<longdescription lang="en">
- The C-library cddlib is a C implementation of the Double Description
+ The C-library cddlib is a C implementation of the Double Description
Method of Motzkin et al. for generating all vertices (i.e. extreme points)
- and extreme rays of a general convex polyhedron in R^d given by a system
+ and extreme rays of a general convex polyhedron in R^d given by a system
of linear inequalities:
-
+
P = { x=(x1, ..., xd)^T : b - A x &gt;= 0 }
- where A is a given m x d real matrix, b is a given m-vector
+ where A is a given m x d real matrix, b is a given m-vector
and 0 is the m-vector of all zeros.
-
+
The program can be used for the reverse operation (i.e. convex hull
- computation). This means that one can move back and forth between
- an inequality representation and a generator (i.e. vertex and ray)
+ computation). This means that one can move back and forth between
+ an inequality representation and a generator (i.e. vertex and ray)
representation of a polyhedron with cdd. Also, cdd can solve a linear
- programming problem, i.e. a problem of maximizing and minimizing
+ programming problem, i.e. a problem of maximizing and minimizing
a linear function over P.
</longdescription>
<use>
<flag name="tools">Add a few executables and tests for cddlib</flag>
</use>
+ <upstream>
+ <remote-id type="github">cddlib/cddlib</remote-id>
+ </upstream>
</pkgmetadata>