summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/polyml/files/polyml-5.9-c++11.patch11
-rw-r--r--dev-lang/polyml/polyml-5.9-r1.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/dev-lang/polyml/files/polyml-5.9-c++11.patch b/dev-lang/polyml/files/polyml-5.9-c++11.patch
new file mode 100644
index 000000000000..4f750fe5a0fb
--- /dev/null
+++ b/dev-lang/polyml/files/polyml-5.9-c++11.patch
@@ -0,0 +1,11 @@
+--- a/libpolyml/xwindows.cpp 2023-01-22 10:40:35.855024465 +0100
++++ b/libpolyml/xwindows.cpp 2023-01-22 10:41:00.798613288 +0100
+@@ -7274,7 +7274,7 @@
+ : printf("Old Display <%p>",P.AsAddress()));
+ return;
+
+- default: printf("Pointer "ZERO_X"%p",P.AsAddress());
++ default: printf("Pointer %p",P.AsAddress());
+ return;
+ }
+ }
diff --git a/dev-lang/polyml/polyml-5.9-r1.ebuild b/dev-lang/polyml/polyml-5.9-r1.ebuild
index fef26cddee79..76dcf8e4fdec 100644
--- a/dev-lang/polyml/polyml-5.9-r1.ebuild
+++ b/dev-lang/polyml/polyml-5.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-5.8.2-configure.patch
+ "${FILESDIR}"/${P}-c++11.patch
)
src_prepare() {