summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/fsharp-mode/Manifest1
-rw-r--r--app-emacs/fsharp-mode/files/50fsharp-mode-gentoo.el4
-rw-r--r--app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild26
-rw-r--r--app-emacs/fsharp-mode/metadata.xml14
4 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/fsharp-mode/Manifest b/app-emacs/fsharp-mode/Manifest
new file mode 100644
index 000000000000..95ba8abd3a8d
--- /dev/null
+++ b/app-emacs/fsharp-mode/Manifest
@@ -0,0 +1 @@
+DIST fsharp-mode-1.10_p20211229.tar.gz 78916 BLAKE2B 4cd9182c62ea0d5c7a23f2120586d4c74d16fad14762ecdb3f11a11d6c78c757b363d5c14473c10c47086c1c0e648911846fe039dfedc04fd1d84301b4aa10c5 SHA512 b02be4c8e56a2c22b7f6e6a302756278d9056e7d8b8c206c183aea5470b98610b73a3403c83e93da295d3b4d0092a4f2f1c0bdf78f701009478a3c8b1e054ab7
diff --git a/app-emacs/fsharp-mode/files/50fsharp-mode-gentoo.el b/app-emacs/fsharp-mode/files/50fsharp-mode-gentoo.el
new file mode 100644
index 000000000000..305be955668d
--- /dev/null
+++ b/app-emacs/fsharp-mode/files/50fsharp-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'fsharp-mode "fsharp-mode"
+ "Major mode for editing fsharp code." t)
+(add-to-list 'auto-mode-alist '("\\.fs[iylx]?\\'" . fsharp-mode))
diff --git a/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild b/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild
new file mode 100644
index 000000000000..f5407ecb598a
--- /dev/null
+++ b/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=b3aa4c53fc9e98648b25ad036e657632ae2fe192
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Support for the F# programming language"
+HOMEPAGE="https://github.com/fsharp/emacs-fsharp-mode/"
+SRC_URI="https://github.com/fsharp/emacs-${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${PN}-${H}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # requires Cask
+
+RDEPEND="app-emacs/s"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.org )
+ELISP_REMOVE="eglot-fsharp.el"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/fsharp-mode/metadata.xml b/app-emacs/fsharp-mode/metadata.xml
new file mode 100644
index 000000000000..f3fd042ec1a6
--- /dev/null
+++ b/app-emacs/fsharp-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/fsharp/emacs-fsharp-mode/blob/master/CHANGELOG.md</changelog>
+ <bugs-to>https://github.com/fsharp/emacs-fsharp-mode/issues/</bugs-to>
+ <remote-id type="github">fsharp/emacs-fsharp-mode</remote-id>
+ </upstream>
+</pkgmetadata>