summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-vpn/vpnc/Manifest1
-rw-r--r--net-vpn/vpnc/vpnc-0.5.3_p550.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/net-vpn/vpnc/Manifest b/net-vpn/vpnc/Manifest
index 8104364d86c4..65c9cf48cbff 100644
--- a/net-vpn/vpnc/Manifest
+++ b/net-vpn/vpnc/Manifest
@@ -1,2 +1 @@
DIST vpnc-0.5.3_p550-r1.tar.gz 133339 BLAKE2B d4f09a62edbe3b4014c4903d908eecf27ee09705017f715aadc869592fb80d7f4482f08e4681dd9e9c22ae16ae185404e09572800de8cb76419c20f5bf8e17d1 SHA512 3adaf4c73c14c328ca9702c1e3d3c333b0a589f99b52990febf7b22ac87f666f1fc0a1d62e9831ec645567ca01425ea476a7bb62fee214012c97651e0e99b732
-DIST vpnc-0.5.3_p550.tar.xz 101860 BLAKE2B 9800ab0704108cd70450dcfe314eba7c09ca1bb329fa6b9f2946dbb6ee6407e5f6bc3d17d8be782e9103d94a12895777125acdad070f39ea1b96a946ba7d2302 SHA512 95150c743c61a962c36591bb874c77f2c28f341c0a1290dba4e878a460d22d762dd88f7cfc0aa9d17ace71a8b826d9fd13554c23b5123dee6009e9fffcd2de55
diff --git a/net-vpn/vpnc/vpnc-0.5.3_p550.ebuild b/net-vpn/vpnc/vpnc-0.5.3_p550.ebuild
deleted file mode 100644
index 6a33ec812e0f..000000000000
--- a/net-vpn/vpnc/vpnc-0.5.3_p550.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils linux-info systemd toolchain-funcs
-
-DESCRIPTION="Free client for Cisco VPN routing software"
-HOMEPAGE="https://www.unix-ag.uni-kl.de/~massar/vpnc/"
-SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
-IUSE="resolvconf +gnutls selinux"
-
-DEPEND="
- dev-lang/perl
- dev-libs/libgcrypt:0=
- >=sys-apps/iproute2-2.6.19.20061214[-minimal]
- gnutls? ( net-libs/gnutls )
- !gnutls? ( dev-libs/openssl:0= )"
-RDEPEND="${DEPEND}
- resolvconf? ( virtual/resolvconf )
- selinux? ( sec-policy/selinux-vpn )
-"
-
-RESTRICT="!gnutls? ( bindist )"
-
-CONFIG_CHECK="~TUN"
-
-src_prepare() {
- if use gnutls; then
- elog "Will build with GnuTLS (default) instead of OpenSSL so you may even redistribute binaries."
- elog "See the Makefile itself and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
- else
- sed -i -e '/^#OPENSSL_GPL_VIOLATION/s:#::g' "${S}"/Makefile || die
- ewarn "Building SSL support with OpenSSL instead of GnuTLS. This means that"
- ewarn "you are not allowed to re-distibute the binaries due to conflicts between BSD license and GPL,"
- ewarn "see the vpnc Makefile and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
- fi
-
- sed -e 's:test/cert0.pem::g' -i Makefile || die
-
- tc-export CC
-
- sed \
- -e 's:/var/run:/run:g' \
- -i ChangeLog config.c TODO || die
-}
-
-src_install() {
- emake PREFIX="/usr" DESTDIR="${D}" install
- dodoc README TODO VERSION
- keepdir /etc/vpnc/scripts.d
- newinitd "${FILESDIR}/vpnc-3.init" vpnc
- newconfd "${FILESDIR}/vpnc.confd" vpnc
- sed -e "s:/usr/local:/usr:" -i "${ED}"/etc/vpnc/vpnc-script || die
-
- systemd_dotmpfilesd "${FILESDIR}"/vpnc-tmpfiles.conf
- systemd_newunit "${FILESDIR}"/vpnc.service vpnc@.service
-
- # COPYING file resides here, should not be installed
- rm -rf "${ED}"/usr/share/doc/vpnc/ || die
-}
-
-pkg_postinst() {
- elog "You can generate a configuration file from the original Cisco profiles of your"
- elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
- elog "A guide is available at https://wiki.gentoo.org/wiki/Vpnc"
-}