summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/elisp-manual/elisp-manual-18.1.03.ebuild13
-rw-r--r--app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild13
-rw-r--r--app-doc/elisp-manual/elisp-manual-20.2.5.ebuild13
-rw-r--r--app-doc/elisp-manual/elisp-manual-21.2.8-r2.ebuild13
-rw-r--r--app-doc/elisp-manual/elisp-manual-22.2.9.ebuild13
-rw-r--r--app-doc/elisp-manual/elisp-manual-23.4.ebuild13
-rw-r--r--app-doc/elisp-manual/elisp-manual-24.5.ebuild11
-rw-r--r--app-doc/elisp-manual/elisp-manual-25.3.ebuild8
-rw-r--r--app-doc/elisp-manual/elisp-manual-26.3.ebuild6
9 files changed, 44 insertions, 59 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild b/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild
index 77e0c00c309b..8beb5471da6f 100644
--- a/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit epatch
+EAPI=7
MY_P=${PN}-${PV/./-}
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
SRC_URI="ftp://ftp.gnu.org/old-gnu/emacs/${MY_P}.tar.gz
https://dev.gentoo.org/~ulm/emacs/${P}-patches.tar.gz"
+S="${WORKDIR}/elisp"
LICENSE="Texinfo-manual"
SLOT="18"
KEYWORDS="amd64 ~ppc x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/elisp"
+PATCHES=("${WORKDIR}/patch")
src_prepare() {
+ default
# remove pre-made info files
- rm -f elisp elisp-[0-9]*
- EPATCH_SUFFIX=patch epatch
+ rm -f elisp elisp-[0-9]* || die
}
src_compile() {
diff --git a/app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild b/app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild
index 19b816d5d800..98109080f591 100644
--- a/app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit epatch
+EAPI=7
MY_P=${PN}-${PV/./-}
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
SRC_URI="ftp://ftp.gnu.org/old-gnu/emacs/${MY_P}.tar.gz
https://dev.gentoo.org/~ulm/emacs/${P}-patches.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="Texinfo-manual"
SLOT="19"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/${MY_P}"
+PATCHES=("${WORKDIR}/patch")
src_prepare() {
+ default
# remove pre-made info files
- rm -f elisp elisp-[0-9]*
- EPATCH_SUFFIX=patch epatch
+ rm -f elisp elisp-[0-9]* || die
}
src_compile() {
diff --git a/app-doc/elisp-manual/elisp-manual-20.2.5.ebuild b/app-doc/elisp-manual/elisp-manual-20.2.5.ebuild
index 8d1b60f332b4..81c347525e3f 100644
--- a/app-doc/elisp-manual/elisp-manual-20.2.5.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-20.2.5.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit epatch
+EAPI=7
MY_P=${PN}-${PV/./-}
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
SRC_URI="ftp://ftp.gnu.org/old-gnu/emacs/${MY_P}.tar.gz
https://dev.gentoo.org/~ulm/emacs/${P}-patches.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="Texinfo-manual"
SLOT="20"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/${MY_P}"
+PATCHES=("${WORKDIR}/patch")
src_prepare() {
+ default
# remove pre-made info files
- rm -f elisp elisp-[0-9]*
- EPATCH_SUFFIX=patch epatch
+ rm -f elisp elisp-[0-9]* || die
}
src_compile() {
diff --git a/app-doc/elisp-manual/elisp-manual-21.2.8-r2.ebuild b/app-doc/elisp-manual/elisp-manual-21.2.8-r2.ebuild
index 094626bf1531..e79aed0390f9 100644
--- a/app-doc/elisp-manual/elisp-manual-21.2.8-r2.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-21.2.8-r2.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit epatch
+EAPI=7
MY_P=${PN}-${PV/./-}
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
SRC_URI="mirror://gnu/emacs/${MY_P}.tar.gz
https://dev.gentoo.org/~ulm/emacs/${P}-patches.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="FDL-1.1+"
SLOT="21"
KEYWORDS="amd64 ppc x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/${MY_P}"
+PATCHES=("${WORKDIR}/patch")
src_prepare() {
+ default
# remove pre-made info files
- rm -f elisp elisp-[0-9]*
- EPATCH_SUFFIX=patch epatch
+ rm -f elisp elisp-[0-9]* || die
}
src_compile() {
diff --git a/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild b/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
index 821eef0693d5..31ea922291cd 100644
--- a/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
@@ -1,27 +1,22 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit epatch
+EAPI=7
MY_P=${PN}-${PV/./-}
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
# Taken from lispref/ of emacs-22.3
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="FDL-1.2+"
SLOT="22"
KEYWORDS="amd64 ppc x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-direntry.patch"
-}
+PATCHES=("${FILESDIR}/${P}-direntry.patch")
src_compile() {
makeinfo elisp.texi || die
diff --git a/app-doc/elisp-manual/elisp-manual-23.4.ebuild b/app-doc/elisp-manual/elisp-manual-23.4.ebuild
index ba51ff8feb27..312276729e84 100644
--- a/app-doc/elisp-manual/elisp-manual-23.4.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-23.4.ebuild
@@ -1,27 +1,22 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit epatch
+EAPI=7
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
# taken from doc/lispref/ of emacs-${PV}
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz
https://dev.gentoo.org/~ulm/emacs/${P}-patches-1.tar.xz"
+S="${WORKDIR}/lispref"
LICENSE="FDL-1.3+"
SLOT="23"
KEYWORDS="amd64 ppc x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/lispref"
-
-src_prepare() {
- EPATCH_SUFFIX=patch epatch
-}
+PATCHES=("${WORKDIR}/patch")
src_compile() {
makeinfo elisp.texi || die
diff --git a/app-doc/elisp-manual/elisp-manual-24.5.ebuild b/app-doc/elisp-manual/elisp-manual-24.5.ebuild
index 0031da0c4b4a..2808e22eab84 100644
--- a/app-doc/elisp-manual/elisp-manual-24.5.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-24.5.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit epatch
+EAPI=7
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
# taken from doc/lispref/ of emacs-${PV}
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+S="${WORKDIR}/lispref"
LICENSE="FDL-1.3+"
SLOT="24"
KEYWORDS="amd64 ppc x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/lispref"
+PATCHES=("${FILESDIR}/${P}-direntry.patch")
src_prepare() {
- epatch "${FILESDIR}/${P}-direntry.patch"
+ default
echo "@set EMACSVER ${PV}" >emacsver.texi || die
}
diff --git a/app-doc/elisp-manual/elisp-manual-25.3.ebuild b/app-doc/elisp-manual/elisp-manual-25.3.ebuild
index e0f8252ce505..5a4e275b704f 100644
--- a/app-doc/elisp-manual/elisp-manual-25.3.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-25.3.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
# taken from doc/lispref/ (and some files from doc/emacs/) of emacs-${PV}
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+S="${WORKDIR}/lispref"
LICENSE="FDL-1.3+"
SLOT="25"
KEYWORDS="amd64 ppc x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/lispref"
PATCHES=("${FILESDIR}/${P}-direntry.patch")
src_compile() {
diff --git a/app-doc/elisp-manual/elisp-manual-26.3.ebuild b/app-doc/elisp-manual/elisp-manual-26.3.ebuild
index 3b811adc9a08..750528469897 100644
--- a/app-doc/elisp-manual/elisp-manual-26.3.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-26.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,14 +7,14 @@ DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
# taken from doc/lispref/ (and some files from doc/emacs/) of emacs-${PV}
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+S="${WORKDIR}/lispref"
LICENSE="FDL-1.3+"
SLOT="26"
KEYWORDS="amd64 ppc x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/lispref"
PATCHES=("${FILESDIR}/${P}-direntry.patch")
src_compile() {