summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/mepl/files/mepl-0.45-gcc433.patch31
-rw-r--r--app-misc/mepl/files/mepl-0.45-makefile.patch19
-rw-r--r--app-misc/mepl/mepl-0.45-r2.ebuild (renamed from app-misc/mepl/mepl-0.45-r1.ebuild)22
3 files changed, 58 insertions, 14 deletions
diff --git a/app-misc/mepl/files/mepl-0.45-gcc433.patch b/app-misc/mepl/files/mepl-0.45-gcc433.patch
index 0fd857a9ae30..baf26c03c4f4 100644
--- a/app-misc/mepl/files/mepl-0.45-gcc433.patch
+++ b/app-misc/mepl/files/mepl-0.45-gcc433.patch
@@ -1,11 +1,34 @@
---- a/mepl.c 2009-04-07 21:17:32.000000000 +0200
-+++ b/mepl.c 2009-04-07 21:16:48.000000000 +0200
+--- a/mepl.c
++++ b/mepl.c
@@ -1,3 +1,4 @@
+#include <stdlib.h>
#define VERSION "0.45 Don Nov 25 19:13:58 CET 1999"
/* Version: @(#) mepl.c 0.45
- Autor: Frank Holtz <frank@hof-berlin.de>--- mepl.c 2009-04-07 21:08:18.000000000 +0200
-@@ -347,7 +347,7 @@
+ Autor: Frank Holtz <frank@hof-berlin.de>
+@@ -18,11 +19,12 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+ #include <fcntl.h>
+-// #include <signal.h> #If you have problems to compile remove the "//"
++#include <signal.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
++#include <sys/wait.h>
+ #include <termios.h>
+ #include <time.h>
+ #include <unistd.h>
+@@ -93,7 +95,7 @@
+ int hex(unsigned char *);
+ int fget(int);
+
+-main(int argc, char *argv[])
++int main(int argc, char *argv[])
+ {
+ int i,z,j,k,error,errz,ic,resin,resout,n,pid,opt;
+ struct termios oldtio,newtio;
+@@ -346,7 +348,7 @@
errz=0;
do {
error=0;
diff --git a/app-misc/mepl/files/mepl-0.45-makefile.patch b/app-misc/mepl/files/mepl-0.45-makefile.patch
new file mode 100644
index 000000000000..cbd89103719a
--- /dev/null
+++ b/app-misc/mepl/files/mepl-0.45-makefile.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,14 +13,9 @@
+ initdir = /etc/rc.d/init.d
+ initdir2 = /etc/init.d
+
+-CC = gcc
+-CFLAGS = -DMEPLCONFIG=\"$(CONFIGFILE)\"
++CPPFLAGS += -DMEPLCONFIG=\"$(CONFIGFILE)\"
+
+-en: mepl.c
+- @echo "Type \"make de\" or \"make installde\" for german version."
+- @echo "Taper \"make fr\" ou \"make installfr\" pour la version française."
+- @echo "Scrivi \"make it\" or \"make installit\" per la versione italiana."
+- $(CC) $(CFLAGS) -o mepl mepl.c
++en: mepl
+
+ de: mepl.c
+ @echo "Type \"make en\" or \"make installen\" for english version."
diff --git a/app-misc/mepl/mepl-0.45-r1.ebuild b/app-misc/mepl/mepl-0.45-r2.ebuild
index 260918797539..7a9c8a94b754 100644
--- a/app-misc/mepl/mepl-0.45-r1.ebuild
+++ b/app-misc/mepl/mepl-0.45-r2.ebuild
@@ -1,29 +1,31 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Self-employed-mode software for 3COM/USR message modems"
HOMEPAGE="https://web.archive.org/web/20031204100644/http://www.hof-berlin.de:80/mepl/"
SRC_URI="http://www.hof-berlin.de/mepl/mepl${PV}.tar.gz"
+S="${WORKDIR}/${PN}${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-S="${WORKDIR}/${PN}${PV}"
-
-PATCHES=( "${FILESDIR}/${P}-gcc433.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-gcc433.patch
+)
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DMEPLCONFIG=\\\"/etc/mepl.conf\\\" ${LDFLAGS}" en
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin "${PN}" "${PN}mail"
+ dobin mepl meplmail
insinto /etc
- doins "${PN}.conf"
- newman "${PN}.en" "${PN}.7"
+ doins mepl.conf
+ newman mepl.en mepl.7
}