summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nagios-check_multiple/Manifest1
-rw-r--r--net-analyzer/nagios-check_multiple/metadata.xml11
-rw-r--r--net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild46
3 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_multiple/Manifest b/net-analyzer/nagios-check_multiple/Manifest
new file mode 100644
index 000000000000..3ed8c1378cb5
--- /dev/null
+++ b/net-analyzer/nagios-check_multiple/Manifest
@@ -0,0 +1 @@
+DIST nagios-check_multiple-0.0.1.tar.gz 9376 BLAKE2B 2db464b7edd4aa704560a3f16a5d70e4cdef7cd35284e3c679f3e10e5ef6eaaba19dc361efbb10a77f87c14726439869e4b415fe7e393a1d7ac23233b3bfa66a SHA512 a75bcd821afc6daca612f42c552fb965a3068dc04a94df41ff41d36928c764d44bcf72e1bd6d776bf4b443c73fc3946c0a91443a562019fcd1b6e8687d0ebcd2
diff --git a/net-analyzer/nagios-check_multiple/metadata.xml b/net-analyzer/nagios-check_multiple/metadata.xml
new file mode 100644
index 000000000000..9956f0ad2444
--- /dev/null
+++ b/net-analyzer/nagios-check_multiple/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">clarkbox/check_multiple</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild b/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild
new file mode 100644
index 000000000000..54b6ca191727
--- /dev/null
+++ b/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PN="check_multiple"
+DESCRIPTION="A Nagios plugin to execute multiple checks in parallel"
+HOMEPAGE="https://github.com/clarkbox/${MY_PN}"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest -v lib/check_multiple/check_multiple.py \
+ || die "test suite failed"
+}