summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/dhcpcd/Manifest1
-rw-r--r--net-misc/dhcpcd/dhcpcd-9.0.0.ebuild175
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-9.0.0-no_ipv6_build_fix.patch92
3 files changed, 0 insertions, 268 deletions
diff --git a/net-misc/dhcpcd/Manifest b/net-misc/dhcpcd/Manifest
index 07ee06427e78..867c3edcba9d 100644
--- a/net-misc/dhcpcd/Manifest
+++ b/net-misc/dhcpcd/Manifest
@@ -3,6 +3,5 @@ DIST dhcpcd-7.2.5.tar.xz 214124 BLAKE2B 7a5f32b66187afcaa2bb4a1cbcc0d704a28a27ff
DIST dhcpcd-8.0.6.tar.xz 224552 BLAKE2B 5d0fab5977597ce182a2de56c8c4d085d3595a8f1209fc76788b707af0fffd4285a958cebfe7bab6c04ae7a2ba94c466d689dc9c3a71708c1baabd328b2bbf3e SHA512 19a568800a4e510a250de7cc111700b364c68bfe3907f1ac2cda81aacd079cb9ac87731cbabbf8f1e85e055a11c7ba88e419f6c4d7b33f8842dfaeadc7d1e193
DIST dhcpcd-8.1.6.tar.xz 229224 BLAKE2B ad3d024b5a62feb3c9cb39ada0323d336af831cb9892dc50b93c672e6ae2a5607526122a9a5f63a00915a182ea7e7a0ae6b19bbb965bd1fa9ca58cbcac81cd66 SHA512 f4d7ea5f4c139a2735e795e13be68f6edac89d86d97589c2cdd67f89b890a093675dcc207c681332e2163b1094da8ce75bda2ee614c19bafd01410d9fadf19df
DIST dhcpcd-8.1.7.tar.xz 230308 BLAKE2B 636daad77885b7f00f34c73413db4a0269bca844c33b630b5302cfcd9f5b2068ed95872dd92f3b8db25e7b2ca0a28a8053e1975a7ee50fd5403f8d58e97dff17 SHA512 ea58ef3db8254d677820c44b2842ef2f3697b2d90fcbd89b2ecfcbac87e705047cac17053bbe076a3f6d2775903c8e75eac38089d25c097e2f24a045c24977e8
-DIST dhcpcd-9.0.0.tar.xz 245336 BLAKE2B e206ba6f8e8c890247e308e5e181abf3eec2f5abc0f4b8fa05b220529018d16c806cb8ae29525b9bf7e39b465377016b55fe1c08b2f0b83d8e7a3432b6ea71b5 SHA512 5b04d9ecb75c45e7f883e29aed4862ae7fc186a6ca161353ed59ffed4dbc266e03596a26d09ae60e87806047659d6ce238b26d264b5a96b21643849343d2da0b
DIST dhcpcd-9.0.1.tar.xz 244816 BLAKE2B 1cb346f7578dadb237d05056a8f6e39b30da831e253e6629c5c19e6a70f7b6d8ffcb6db37d0f720fda28577e8cb4227cbca8a08fac0c977098f66b2a430d9ffe SHA512 dea153c9a2f4a9d9c983bf50d8c18b544d7dbe1a2972ccc8eb33bbbc8b09178b39bdb9a38cc293db7861024509ccd475e11d84004bc4cd45947786f5e10db0a3
DIST dhcpcd-9.0.2.tar.xz 244800 BLAKE2B d0c355141aa1e57715c30b2902eed7e2821f2c08fdc97497c9dc271689faf2ca22e3f50f17e6c7ae8fe4434d5c216572a42e1abf789287495e6db44f671d5085 SHA512 2a606bff2e96d1da5d3642ac68341c14b378d9a905cba364ab42eba1285604f8be56b9efeff3eee18d89b71f0f9f3b05cb7b88e8fce568baf1c0d1e5d3becb5f
diff --git a/net-misc/dhcpcd/dhcpcd-9.0.0.ebuild b/net-misc/dhcpcd/dhcpcd-9.0.0.ebuild
deleted file mode 100644
index 52553bf20cc2..000000000000
--- a/net-misc/dhcpcd/dhcpcd-9.0.0.ebuild
+++ /dev/null
@@ -1,175 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd toolchain-funcs
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://roy.marples.name/cgit/dhcpcd.git"
-else
- MY_P="${P/_alpha/-alpha}"
- MY_P="${MY_P/_beta/-beta}"
- MY_P="${MY_P/_rc/-rc}"
- SRC_URI="https://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${MY_P}"
-fi
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="https://roy.marples.name/projects/dhcpcd"
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="debug elibc_glibc +embedded ipv6 kernel_linux +privsep +udev"
-
-COMMON_DEPEND="udev? ( virtual/udev )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="
- ${COMMON_DEPEND}
- privsep? (
- acct-group/dhcpcd
- acct-user/dhcpcd
- )
-"
-
-PATCHES=( "${FILESDIR}/${P}-no_ipv6_build_fix.patch" )
-
-src_configure() {
- local myeconfargs=(
- --dbdir="${EPREFIX}/var/lib/dhcpcd"
- --libexecdir="${EPREFIX}/lib/dhcpcd"
- --localstatedir="${EPREFIX}/var"
- --prefix="${EPREFIX}"
- --with-hook=ntp.conf
- $(use_enable debug)
- $(use_enable embedded)
- $(use_enable ipv6)
- $(use_enable privsep)
- $(usex elibc_glibc '--with-hook=yp.conf' '')
- $(usex kernel_linux '--rundir=${EPREFIX}/run' '')
- $(usex privsep '--privsepuser=dhcpcd' '')
- $(usex udev '' '--without-dev --without-udev')
- CC="$(tc-getCC)"
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- keepdir /var/lib/dhcpcd
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- local dbdir="${EROOT}"/var/lib/dhcpcd old_files=()
-
- local old_old_duid="${EROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local old_duid="${EROOT}"/etc/dhcpcd.duid
- local new_duid="${dbdir}"/duid
- if [[ -e "${old_old_duid}" ]] ; then
- # Upgrade the duid file to the new format if needed
- if ! grep -q '..:..:..:..:..:..' "${old_old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [[ ! -e "${old_duid}" ]] ; then
- cp -p "${old_old_duid}" "${new_duid}"
- fi
- old_files+=( "${old_old_duid}" )
- fi
-
- # dhcpcd-7 moves the files out of /etc
- if [[ -e "${old_duid}" ]] ; then
- if [[ ! -e "${new_duid}" ]] ; then
- cp -p "${old_duid}" "${new_duid}"
- fi
- old_files+=( "${old_duid}" )
- fi
- local old_secret="${EROOT}"/etc/dhcpcd.secret
- local new_secret="${dbdir}"/secret
- if [[ -e "${old_secret}" ]] ; then
- if [[ ! -e "${new_secret}" ]] ; then
- cp -p "${old_secret}" "${new_secret}"
- fi
- old_files+=( "${old_secret}" )
- fi
-
- # dhcpcd-7 renames some files in /var/lib/dhcpcd
- local old_rdm="${dbdir}"/dhcpcd-rdm.monotonic
- local new_rdm="${dbdir}"/rdm_monotonic
- if [[ -e "${old_rdm}" ]] ; then
- if [[ ! -e "${new_rdm}" ]] ; then
- cp -p "${old_rdm}" "${new_rdm}"
- fi
- old_files+=( "${old_rdm}" )
- fi
- local lease=
- for lease in "${dbdir}"/dhcpcd-*.lease*; do
- [[ -f "${lease}" ]] || continue
- old_files+=( "${lease}" )
- local new_lease=$(basename "${lease}" | sed -e "s/dhcpcd-//")
- [[ -e "${dbdir}/${new_lease}" ]] && continue
- cp "${lease}" "${dbdir}/${new_lease}"
- done
-
- # dhcpcd-9 introduced privesep support in a chroot
- if use privsep ; then
- local dhcpcd_libdir="/var/lib/dhcpcd"
- local chroot_base="${EROOT}/var/chroot/dhcpcd"
- local chroot_dir="${chroot_base}${dhcpcd_libdir}"
- local chroot_retval=0
- # Set up proper chroot.
- if [[ ! -e "${chroot_dir}" ]] ; then
- mkdir -p "${chroot_dir}" || chroot_retval=1
- cp -a "${EROOT}${dhcpcd_libdir}" "${chroot_dir}" || chroot_retval=1
- chown -R dhcpcd:dhcpcd "${chroot_dir}" || chroot_retval=1
- elif [[ ! -d "${chroot_dir}" ]] ; then
- ewarn "${chroot_dir} is not a directory!"
- ewarn "Did not set up ${PN} chroot!"
- fi
- if [[ "${chroot_retval}" -ne 0 ]] ; then
- ewarn "There were issues setting up ${PN} chroot."
- fi
- fi
-
- # Warn about removing stale files
- if [[ -n "${old_files[@]}" ]] ; then
- elog
- elog "dhcpcd-7 has copied dhcpcd.duid and dhcpcd.secret from"
- elog "${EROOT}/etc to ${dbdir}"
- elog "and copied leases in ${dbdir} to new files with the dhcpcd-"
- elog "prefix dropped."
- elog
- elog "You should remove these files if you don't plan on reverting"
- elog "to an older version:"
- local old_file=
- for old_file in ${old_files[@]}; do
- elog " ${old_file}"
- done
- fi
-
- if [ -z "${REPLACING_VERSIONS}" ]; then
- elog
- elog "dhcpcd has zeroconf support active by default."
- elog "This means it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the noipv4ll configuration"
- elog "file option or the -L command line switch."
- elog "See the dhcpcd and dhcpcd.conf man pages for more details."
-
- elog
- elog "Dhcpcd has duid enabled by default, and this may cause issues"
- elog "with some dhcp servers. For more information, see"
- elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
- fi
-
- if ! has_version net-dns/bind-tools; then
- elog
- elog "If you activate the lookup-hostname hook to look up your hostname"
- elog "using the dns, you need to install net-dns/bind-tools."
- fi
-}
diff --git a/net-misc/dhcpcd/files/dhcpcd-9.0.0-no_ipv6_build_fix.patch b/net-misc/dhcpcd/files/dhcpcd-9.0.0-no_ipv6_build_fix.patch
deleted file mode 100644
index a210982c340b..000000000000
--- a/net-misc/dhcpcd/files/dhcpcd-9.0.0-no_ipv6_build_fix.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From 12ddbee51f0e1cf4372146f8d42ea404dd07dba3 Mon Sep 17 00:00:00 2001
-From: Roy Marples <roy@marples.name>
-Date: Thu, 2 Apr 2020 19:54:19 +0000
-Subject: Fix build without INET or INET6
-
----
- src/dhcpcd.c | 2 +-
- src/if-bsd.c | 2 ++
- src/if-options.c | 6 ++++++
- src/privsep-root.c | 2 ++
- 4 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/src/dhcpcd.c b/src/dhcpcd.c
-index 057a1fd9..9208f37c 100644
---- a/src/dhcpcd.c
-+++ b/src/dhcpcd.c
-@@ -2169,7 +2169,7 @@ printpidfile:
- }
- #endif
-
--#ifdef BSD
-+#if defined(BSD) && defined(INET6)
- /* Disable the kernel RTADV sysctl as early as possible. */
- if (ctx.options & DHCPCD_IPV6 && ctx.options & DHCPCD_IPV6RS)
- if_disable_rtadv();
-diff --git a/src/if-bsd.c b/src/if-bsd.c
-index dbe5c359..d6c38903 100644
---- a/src/if-bsd.c
-+++ b/src/if-bsd.c
-@@ -1524,6 +1524,8 @@ if_missfilter0(struct dhcpcd_ctx *ctx, struct interface *ifp,
- #ifdef INET6
- if (sa->sa_family == AF_INET6)
- ifa_setscope(satosin6(sa), ifp->index);
-+#else
-+ UNUSED(ifp);
- #endif
-
- cp = ctx->rt_missfilter + ctx->rt_missfilterlen;
-diff --git a/src/if-options.c b/src/if-options.c
-index 7850ff2e..1280cfbd 100644
---- a/src/if-options.c
-+++ b/src/if-options.c
-@@ -573,6 +573,8 @@ set_option_space(struct dhcpcd_ctx *ctx,
- return;
- }
- #endif
-+#else
-+ UNUSED(arg);
- #endif
-
- #ifdef INET
-@@ -1275,6 +1277,7 @@ parse_option(struct dhcpcd_ctx *ctx, const char *ifname, struct if_options *ifo,
- memset(ifo->nomask6, 0xff, sizeof(ifo->nomask6));
-
- /* Allow the bare minimum through */
-+#ifdef INET
- del_option_mask(ifo->nomask, DHO_SUBNETMASK);
- del_option_mask(ifo->nomask, DHO_CSR);
- del_option_mask(ifo->nomask, DHO_ROUTER);
-@@ -1286,11 +1289,14 @@ parse_option(struct dhcpcd_ctx *ctx, const char *ifname, struct if_options *ifo,
- del_option_mask(ifo->nomask, DHO_RENEWALTIME);
- del_option_mask(ifo->nomask, DHO_REBINDTIME);
- del_option_mask(ifo->nomask, DHO_DNSSEARCH);
-+#endif
-
-+#ifdef INET6
- del_option_mask(ifo->nomask6, D6_OPTION_DNS_SERVERS);
- del_option_mask(ifo->nomask6, D6_OPTION_DOMAIN_LIST);
- del_option_mask(ifo->nomask6, D6_OPTION_SOL_MAX_RT);
- del_option_mask(ifo->nomask6, D6_OPTION_INF_MAX_RT);
-+#endif
-
- break;
- #ifdef INET
-diff --git a/src/privsep-root.c b/src/privsep-root.c
-index f88f56dd..0f099bb7 100644
---- a/src/privsep-root.c
-+++ b/src/privsep-root.c
-@@ -435,8 +435,10 @@ ps_root_dispatchcb(void *arg, struct ps_msghdr *psm, struct msghdr *msg)
- struct dhcpcd_ctx *ctx = arg;
- ssize_t err;
-
-+#ifdef INET
- err = ps_bpf_dispatch(ctx, psm, msg);
- if (err == -1 && errno == ENOTSUP)
-+#endif
- err = ps_inet_dispatch(ctx, psm, msg);
- return err;
- }
---
-cgit v1.2.3
-