summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.9.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index 9f3f47c56933..20e3345a3882 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1 +1,2 @@
DIST ansi2html-1.8.0.tar.gz 44146 BLAKE2B 66672927a64ad38dce0b0819fabc3778f6aba82d176e992630a8db076988a21af8dd445306b8bb580f1539b35044b95de749d6bfb65c27f9b431e4cb6bd562c7 SHA512 cbdda41f206ced5b19761a1ff9747acc6cadca3a5a2f58c97c6073db7d517e59fea7601bba28a8e7e105f3c0c9c4d78ca4f242100cbded6c8a9ca2d598de0ab4
+DIST ansi2html-1.9.1.tar.gz 44288 BLAKE2B ff83d2a9fe74766324515e7ccde5c6d157f836d655c6c55a07f0b9c4ab5df9c8a840f0c35e752a3e24f3e12fbd73565c2906382d77c2daf5951e861e18bdcb46 SHA512 1ffeffdd4f861b809c424b5b9e7d07212aaf1b5ef483a2820f128f815002628c823b5701652b0770ed182f0585052f040b55fca5db31e4690be86c49553105b3
diff --git a/dev-python/ansi2html/ansi2html-1.9.1.ebuild b/dev-python/ansi2html/ansi2html-1.9.1.ebuild
new file mode 100644
index 000000000000..9cfb2258e2e1
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.9.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="
+ https://pypi.org/project/ansi2html/
+ https://github.com/pycontribs/ansi2html/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest