summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/po4a/Manifest1
-rw-r--r--app-text/po4a/po4a-0.45-r3.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/app-text/po4a/Manifest b/app-text/po4a/Manifest
index 4f42107bf886..0527fd23e3d7 100644
--- a/app-text/po4a/Manifest
+++ b/app-text/po4a/Manifest
@@ -1,2 +1 @@
-DIST po4a_0.45.orig.tar.gz 2208959 BLAKE2B f5fd533036eac41aa15413559bab7fb176556b47d63fe7bae4a98797a128f8314f6a22076fd1792d1ae19d8aad27599508064ec8323b6fe8ffd433989541151e SHA512 e67334b7a45d3c23b7226077e01e12b3c4f1202531596f02851b6a9e7249b2b8a0c37f37ebbaf591753f041a4c6ce42c062b4822e91ac75884dcd0994c27323f
DIST po4a_0.47.orig.tar.gz 2389750 BLAKE2B 72cd81e10f638a660e201b0c733b08c316aa75dd29b054bbc4c645c265b9e7745ce762305a8296f8cc37d2f182755dfa1394861f6c471cff1c7c398d13ac28cc SHA512 9c459a9795977a39aacc09cfb6ddbdc7dd2174e22896fa7bde90510a43ea833054aef558f7ca798991addc052a2c7f91ee11e5d49658a5c80a9ecb9c135ff97a
diff --git a/app-text/po4a/po4a-0.45-r3.ebuild b/app-text/po4a/po4a-0.45-r3.ebuild
deleted file mode 100644
index 3523e66bb77e..000000000000
--- a/app-text/po4a/po4a-0.45-r3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PLOCALES="af ca cs da de eo es et eu fr hr id it ja kn ko nb nl pl pt_BR pt ru sl sv uk vi zh_CN zh_HK"
-PLOCALES_BACKUP="en"
-
-# Needed because this package also installs to vendor_perl
-GENTOO_DEPEND_ON_PERL_SUBSLOT="yes"
-inherit perl-app perl-module l10n
-
-DESCRIPTION="Tools for helping translation of documentation"
-HOMEPAGE="http://po4a.alioth.debian.org"
-SRC_URI="mirror://debian/pool/main/p/po4a/${PN}_${PV}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-RDEPEND="dev-perl/SGMLSpm
- >=sys-devel/gettext-0.13
- app-text/openjade
- dev-libs/libxslt
- dev-perl/Locale-gettext
- dev-perl/TermReadKey
- dev-perl/Text-WrapI18N"
-DEPEND="${RDEPEND}
- >=dev-perl/Module-Build-0.380.0
- app-text/docbook-xsl-stylesheets
- app-text/docbook-xml-dtd:4.1.2
- test? ( app-text/docbook-sgml-dtd
- app-text/docbook-sgml-utils
- virtual/tex-base )"
-
-SRC_TEST="do"
-
-src_prepare() {
- # Check against locale files in ${S}/pod/bin for mismatches
- # with languages listed in PLOCALES
- local locales_path="$S/po/bin"
- l10n_find_plocales_changes "$locales_path" "" ".po"
-
- # Array containing locale files to remove
- local locales_to_remove=( )
-
- # Get rid of disabled locales
- my_get_disabled_locales() {
- locales_to_remove=( "${locales_to_remove[@]}" "po/bin/${1}.po" "po/pod/${1}.po" )
- }
-
- l10n_for_each_disabled_locale_do my_get_disabled_locales
-
- einfo "Your LINGUAS lists the following languages: $LINGUAS"
- einfo "Removing locale files not listed in it ..."
-
- # Fix bad escaping of '.' in @INC modification
- epatch "${FILESDIR}/${P}-614122-no-dot-inc.patch"
-
- # perl_rm_files also updates the Manifest file
- # and therefore silences Perl as to .po files we're about to clean
- perl_rm_files "${locales_to_remove[@]}"
-}