summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libnfsidmap/Manifest1
-rw-r--r--net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch22
-rw-r--r--net-libs/libnfsidmap/files/libnfsidmap-0.27-getgrouplist.patch115
-rw-r--r--net-libs/libnfsidmap/libnfsidmap-0.27-r1.ebuild56
-rw-r--r--net-libs/libnfsidmap/metadata.xml8
-rw-r--r--profiles/package.mask6
6 files changed, 0 insertions, 208 deletions
diff --git a/net-libs/libnfsidmap/Manifest b/net-libs/libnfsidmap/Manifest
deleted file mode 100644
index 5c73486bf1a9..000000000000
--- a/net-libs/libnfsidmap/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libnfsidmap-0.27.tar.bz2 303900 BLAKE2B c6cb8d81042426552fd3cde9dfd26f805d3c92281a65c3ca2d12671477eb697f3cd51a6d8313a658eb70232136e5615e0cb9ad090a92e747e245f49e60cfcf8a SHA512 0698079abb4bb9ebeaccbcabca725b022c1daaa3d287944d9c4c2a2134489b649b44fcbcd9916e91dd6d91cdc67d267adf5741c5404150c66cc8243b9f15970d
diff --git a/net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch b/net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch
deleted file mode 100644
index 6ef12d44e44f..000000000000
--- a/net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-for toupper and such
-
---- a/nss.c
-+++ b/nss.c
-@@ -34,6 +34,7 @@
- * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-+#include <ctype.h>
- #include <sys/types.h>
- #include <errno.h>
- #include <unistd.h>
---- a/libnfsidmap.c
-+++ b/libnfsidmap.c
-@@ -37,6 +37,7 @@
- * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-+#include <ctype.h>
- #include <sys/types.h>
- #include <errno.h>
- #include <unistd.h>
diff --git a/net-libs/libnfsidmap/files/libnfsidmap-0.27-getgrouplist.patch b/net-libs/libnfsidmap/files/libnfsidmap-0.27-getgrouplist.patch
deleted file mode 100644
index 9a8f0a487ae3..000000000000
--- a/net-libs/libnfsidmap/files/libnfsidmap-0.27-getgrouplist.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-http://bugs.gentoo.org/169909
-
---- libnfsidmap-0.27/configure.ac
-+++ libnfsidmap-0.27/configure.ac
-@@ -63,7 +63,7 @@
-
- # Checks for library functions.
- AC_FUNC_MALLOC
--AC_CHECK_FUNCS([strchr strdup])
-+AC_CHECK_FUNCS([strchr strdup getgrouplist])
-
- AC_CONFIG_FILES([Makefile])
- AC_CONFIG_FILES([libnfsidmap.pc])
---- libnfsidmap-0.27/getgrouplist.c
-+++ libnfsidmap-0.27/getgrouplist.c
-@@ -0,0 +1,88 @@
-+/*
-+ * getgrouplist.c
-+ *
-+ * if system does not provide the non-standard getgrouplist, we will emulate
-+ * it via POSIX standard functions
-+ *
-+ * Copyright (c) 1991, 1993
-+ * The Regents of the University of California. All rights reserved.
-+ *
-+ * Redistribution and use in source and binary forms, with or without
-+ * modification, are permitted provided that the following conditions
-+ * are met:
-+ * 1. Redistributions of source code must retain the above copyright
-+ * notice, this list of conditions and the following disclaimer.
-+ * 2. Redistributions in binary form must reproduce the above copyright
-+ * notice, this list of conditions and the following disclaimer in the
-+ * documentation and/or other materials provided with the distribution.
-+ * 4. Neither the name of the University nor the names of its contributors
-+ * may be used to endorse or promote products derived from this software
-+ * without specific prior written permission.
-+ *
-+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
-+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
-+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-+ * SUCH DAMAGE.
-+ */
-+
-+#ifdef HAVE_CONFIG_H
-+#include "config.h"
-+#endif
-+#include <sys/types.h>
-+#include <grp.h>
-+#include <string.h>
-+#include <unistd.h>
-+
-+#ifndef HAVE_GETGROUPLIST
-+static
-+int
-+getgrouplist(const char *uname, gid_t agroup, gid_t *groups, int *grpcnt)
-+{
-+ const struct group *grp;
-+ int i, maxgroups, ngroups, ret;
-+
-+ ret = 0;
-+ ngroups = 0;
-+ maxgroups = *grpcnt;
-+ /*
-+ * When installing primary group, duplicate it;
-+ * the first element of groups is the effective gid
-+ * and will be overwritten when a setgid file is executed.
-+ */
-+ groups[ngroups++] = agroup;
-+ if (maxgroups > 1)
-+ groups[ngroups++] = agroup;
-+ /*
-+ * Scan the group file to find additional groups.
-+ */
-+ setgrent();
-+ while ((grp = getgrent()) != NULL) {
-+ for (i = 0; i < ngroups; i++) {
-+ if (grp->gr_gid == groups[i])
-+ goto skip;
-+ }
-+ for (i = 0; grp->gr_mem[i]; i++) {
-+ if (!strcmp(grp->gr_mem[i], uname)) {
-+ if (ngroups >= maxgroups) {
-+ ret = -1;
-+ break;
-+ }
-+ groups[ngroups++] = grp->gr_gid;
-+ break;
-+ }
-+ }
-+skip:
-+ ;
-+ }
-+ endgrent();
-+ *grpcnt = ngroups;
-+ return (ret);
-+}
-+#endif
---- libnfsidmap-0.27/nss.c
-+++ libnfsidmap-0.27/nss.c
-@@ -51,6 +51,8 @@
- #include "cfg.h"
- #include <syslog.h>
-
-+#include "getgrouplist.c"
-+
- /*
- * NSS Translation Methods
- *
diff --git a/net-libs/libnfsidmap/libnfsidmap-0.27-r1.ebuild b/net-libs/libnfsidmap/libnfsidmap-0.27-r1.ebuild
deleted file mode 100644
index 2d736e7faf37..000000000000
--- a/net-libs/libnfsidmap/libnfsidmap-0.27-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="NFSv4 ID <-> name mapping library"
-HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
-#SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${P}.tar.gz"
-SRC_URI="https://fedorapeople.org/~steved/${PN}/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="ldap static-libs"
-
-DEPEND="ldap? ( net-nds/openldap:= )"
-RDEPEND="
- ${DEPEND}
- !<net-fs/nfs-utils-1.2.2
- !net-fs/idmapd
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.27-getgrouplist.patch #169909
- "${FILESDIR}"/${PN}-0.21-headers.patch
-)
-
-src_prepare() {
- default
- # Ideally the build would use -DLIBDIR=$(libdir) at build time.
- sed -i \
- -e "/PATH_PLUGINS/s:/usr/lib/libnfsidmap:${EPREFIX}/usr/$(get_libdir)/libnfsidmap:" \
- libnfsidmap.c || die #504666
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_enable ldap)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- insinto /etc
- doins idmapd.conf
-
- # remove useless files
- rm -f "${ED%/}"/usr/$(get_libdir)/libnfsidmap/*.{a,la}
- use static-libs || find "${ED%/}"/usr -name '*.la' -delete || die
-}
diff --git a/net-libs/libnfsidmap/metadata.xml b/net-libs/libnfsidmap/metadata.xml
deleted file mode 100644
index 73dda144f9ac..000000000000
--- a/net-libs/libnfsidmap/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 8deef505af87..e25397f36f11 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -368,12 +368,6 @@ net-fs/smbtad
# bug #774495. Dead HOMEPAGE. Removal on 2022-03-27.
dev-libs/smack
-# Andreas K. Hüttel <dilfridge@gentoo.org> (2022-02-27)
-# Outdated, fails to build with glibc-2.34, bug 806755
-# Has been integrated into net-fs/nfs-utils, please use that instead.
-# Removal in 30 days.
-net-libs/libnfsidmap
-
# Andreas Sturmlechner <asturm@gentoo.org> (2022-02-27)
# No revdeps since begin of gentoo.git history, outdated and unmaintained.
# Bug #834307. Removal on 2022-03-29.