summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/towncrier/Manifest1
-rw-r--r--dev-python/towncrier/towncrier-21.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/towncrier/Manifest b/dev-python/towncrier/Manifest
index 6e0aafcd659e..26f016e30faa 100644
--- a/dev-python/towncrier/Manifest
+++ b/dev-python/towncrier/Manifest
@@ -1,2 +1,3 @@
DIST towncrier-19.2.0.tar.gz 18089 BLAKE2B d1e17e707b90089b19d9eedebd898b71fcc9a582cbae0166650a6bd52a8ac6bb3921a458a6d2c10e5930b92230ddf5efc5a428646c464edb6eb4bfc06949e217 SHA512 60999446c4ae404fb54ea6282a862621d49f62a2488d31eecf8fed9dd7afa6e01f4feac6e3dd26b882ee75f747424d63d05521e33b5f6b8df7059ce32dbe5c4f
DIST towncrier-19.9.0.tar.gz 23674 BLAKE2B 89f1c9ac98f5d5505d43a10252e70c5d4fce2e304604582e33c72de460313227382bf73a3b8b7d56b42274aff5587cc092b477649a4d74dd2491a6c7a14f6fa5 SHA512 089a493df6a8e9f8459c1f4cf497a9f4f647d1d907f13cbf716e6b1e79a591570daf40c19bf7bceaf44a1890187ea912aef6f38e82251194dfba16edb933374c
+DIST towncrier-21.3.0.tar.gz 31787 BLAKE2B 1ad54cb2eb28d25131be13a7fce5aeec3df07fe198f3200202d612b2b49cbef76d422025e143b19db498af224ba522f3a67b66fc10ec2cfb0ab81a52aeb7263e SHA512 b6093864d590849e29311fd1a085cc40997f88ada38e92bf159d72fd809691e014f67ac87844886cfdb27be0f9abc8fbf79d5d7e800688eac34e9edec6d6a2f6
diff --git a/dev-python/towncrier/towncrier-21.3.0.ebuild b/dev-python/towncrier/towncrier-21.3.0.ebuild
new file mode 100644
index 000000000000..43141a036fe5
--- /dev/null
+++ b/dev-python/towncrier/towncrier-21.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Building newsfiles for your project"
+HOMEPAGE="https://github.com/twisted/towncrier"
+SRC_URI="https://github.com/twisted/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-default-group[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ distutils_install_for_testing
+ trial towncrier || die "tests failed with ${EPYTHON}"
+}